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Abstract

This document is a handbook for using SciDAVis, a program for two- and three-
dimensional graphical presentation of data sets and for data analysis.

This manual is organized in several chapters:

-The first one describes the main concepts and terms which are used in SciDAVis.

- The second chapter is a tutorial on how to obtain plots from different data sets. It
is the one you need to read first to understand the basics of SciDAVis and to be able to
draw plots.

- The three following chapters are descriptions of all the commands, buttons and
dialogs used in SciDAVis. These chapters are the reference manual of SciDAVis.

- The two following chapters describe more deeply some specific possibilities of
SciDAVis, that is the statistical and mathematical analysis of data, and the scripting.



Chapter 1

Introduction

1.1 What is SciDAVis?

SciDAVis stands for Scientific Data Analysis and Visualization. It is a free cross-
platform program for two- and three-dimensional graphical presentation of data sets
and for data analysis. The plots can be produced from data sets stored in tables or from
analytical functions.

The SciDAVis project started as a fork of QtiPlot with the aim of introducing some
changes in design as well as project structure. The QtiPlot development was initiated
in 2004 by Ion Vasilief. He was the only programmer until May 2006 when Knut
Franke and Tilman Hoener zu Siederdissen joined the project. Not much later, Roger
Gadiou officially joined as the main documentation writer. In June 2007, insuperable
disagreements among the developers lead to the fork and the creation of the SciDAVis
project by Knut Franke and Tilman Hoener zu Siederdissen, soon followed by Roger
Gadiou. The project is hosted at Sourceforge.

SciDAVis aims to be a tool for analysis and graphical representation of data, allow-
ing powerfull mathematical treatment and visualization of scientific data while keeping
a user-friendly graphical user interface. Another keypoint for the SciDAVis project is
to be a multi-system software, it should work on Windows, Linux, and OS-X systems.

SciDAVis is a dynamic tool, the plots created from data sets and the spreadsheets
owing the data are interconected. When the spreadsheets are modified, all the objects
in the depending plots (curves, axes scales, legends) are automatically updated. For
example, deleting a spreadsheet or only some columns will automatically remove all
the corresponding curves from the depending plots.

All settings of a complete set of tables, matrix and plots can be saved in project files,
having the extention ".sciprj". These project files may be opened using the command
line, or using the File menu, or by using the Open project icon from the File toolbar.

The plots can be exported to several graphic formats such as JPEG or PNG and
inserted as images in documents or presentations.

Data analysis operations (integration, interpolation, FFT, curve fitting, etc...) can
be performed on the curves in a 2D plot via the Analysis menu. The results of all these
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operations are also stored in the project files. They can be visualized at any moment
using the Results log command and can be deleted from the project file via the Clear
Log Informations command.

When the application is launched, a new project file is created consisting of a grey
main window (the workspace) which contains an empty table. In order to be opera-
tional, this workspace must be populated with tables storing data sets, either by creating
empty tables first (New -> New Table command) and then filling them with data, or by
importing ASCII files (Import ASCII -> Single File... command), which automatically
creates new tables.

The user can easily navigate through the objects of a project file using the project
explorer or the Windows menu. The project explorer also allows the user to perform
various operations on the windows (tables and plots) in the workspace: hiding, mini-
mazing, closing, renaming, printing, etc...

1.2 Command Line Parameters

1.2.1 Specify a File

When starting SciDAVis from the command prompt, you can supply the name of a
project file:

SciDAVis file_name.sciprj

Other file format are also accepted: .opj, .ogm, .ogw, .0ogg for Origin projects, and
.qti, gti.gz for Qtiplot projects.
The name can also refer to an ASCII file:

SciDAVis ASCII_file_name

In this latter case a new "untitled" project will be created, containing a spreadsheet
with the ASCII data in the file and a 2D plot of all columns as a function of the first
column in the file. You must take care of the format of the ASCII file because it will
be read with the current values of the Set Import Options... command dialog. These
default values are:

* the default field separator is ; but it can be changed in the Preferences... command
dialog,

« all lines are read,
* the first line is used to name the columns,
* the spaces at the end of the lines are not removed,

* the spaces are not simplified.



1.2.2 Command Line Options
Valid options are:
e -a or --about: show about dialog and exit
* -h or --help: show command line options
e -]=XX or --lang=XX: start SciDAVis in language XX (’en’, ’fr’, °de’, ...)
* -m or --manual: show SciDAVis manual in a standalone window
e -v or --version: print SciDAVis version and release date

* -x or --execute: execute the script file given as argument

1.3 General Concepts and Terms

Several plots and all the data related to these plots can be save in a project file, the
project is therefore the main container of SciDAVis. The following screenshot gives
an example of a typical session. This example shows the log panel at the top of the
workspace, the project explorer at the bottom, a table and a plot window are shown
while other are docked or hidden.



SciDAVis - /home/roger/exemple-session.sciprj
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Figure 1.1: A typical SciDAVis session

There are numerous commands available in SciDAVis depending on the element
which is selected. Therefore, the main menu bar changes when you select a particular
element of the project. Moreover, you can access to the set of commands relevant of
an element by activating the context menu with the right button of the mouse.

In a project, the containers which can be used are:

A Table A table is a spreadsheet which can be used to store the datas you are entering.
It can also be used to do some calculations and statistical analysis of datas. In
each table, columns can be labelled as X-values or Y-values for 2D-plotting, or
Z-values if you plan to build a 3D-plot.

A table can be created by the New -> New Table command. Then there are
several ways to fill the table with your data. If you want to read a table from an
ASCII file, you can import the data from the file to a table with the Import ASCII
-> Single File... command. You can also enter each value from the keyboard. The



last way to enter your data is to fill the table with the results of a mathematical
function (Set Column Values... command from the Table menu)

A Matrix A matrix is a special table which is used to store the data points for surface
3D plots. It contains Z-values and doesn’t include any column or row which
could be designed as X-values or Y-values. Nevertheless, you can specify the
X-values and the Y-values with the Set Dimensions... command command from
the Matrix menu.

A matrix can be created by the New -> New Matrix command. If you want to
read a matrix from an ASCII file, you can import the data of the file to a table
with the Import ASCII -> Single File... command and then convert this table to a
matrix with the Convert to Matrix command. In the same way as for tables, you
can also fill matrix with the results of a function z=(i,j) in which i and j are row
and column numbers (Set Values... command from the Matrix menu)

A Graph A graph can contain one or several plots. Each of these plots is contained in
a different layer, these layers can be arranged in many ways to build matrix of
plots.

A new layer can be added to an existing graph with the Add Layer command
from the Graph menu. you can also remove an existing layer with the Remove
Layer command, but if you remove a layer, the plot will be deleted. You can also
copy a layer from one graph to another. You can also copy an existing graph into
another, the window will be added as a new layer (see the section on Multilayer
Plots for more details).

Plots can be created in several ways. You can select data in tables or matrix
and build a plot, or create new plots from functions of one or two variables (see
sections 2D plots and 3D plots).

A Note This window is a text container which can simply be used to insert comments
into a project, but is really far more powerfull than that. It can be used as a
calculator, for executing single commands and for writing scripts.

The Log Window This window is used to store the results of all the calculations
which have been done. If this window is not visible, you can find it with the
Project Explorer or with the Results log command.

The text in the log window is also saved in the project file, so that when you load
a previously saved project, the results-log panel is re-filled with the results of the
calculations.

The Project Explorer This window is used to list all the windows contained in a pro-
jet. The Project Explorer gives a quick access to all elements of a project, hidden
or visibles. It can be used to do some operations on the windows related to these
items such as hidding a window, renaming windows, etc.

Since the version 0.8.5, a project file can include several independant projects.
In this case, the containers of each project are stored in different folders.



1.3.1 Tables

The table is the main part of SciDAVis when working with data. For controlling and
converting data the spreadsheet contains a highly customizable table: all colors and font
preferences can be set using the Preferences... command of the View menu. You can
resize a table in terms of rows and columns using the Table menu with Rows command
or Columns command.

a# tablel - (x,y) with errors

X =r TN Line
1] 1.00 .o
— : : " Scatter
2 2.20 ~" Line + symbol
El 3.00 e
Special Line/Symbgl »
| 4.00
5| 550 7.20 Set as » il Columns
Il 7.00 8.30 Set column values... B Rrows
7| 9.20 6.20 Eill column with » Area
8 10.00 5.50 Normalize » & Pie
9| 11.00 3.20 o.16 M =8 statistics on Columns # 3D Ribbon
3DB
@ Clear w o
f2 3D Scatter
b Rl & 3D Trajectory
[ Statistical Graphs »
Add column
Sort Column »
Sort Table
Properties

Figure 1.2: The SciDAVis table

Every column of the table has a label and can be assigned a format: numeric, text,
date or time. In a spreadsheet, columns can have the following flags: X, Y, Z, X-
error, Y-error or can be simple columns without any special flag. The X columns are
abscissae columns while the Y columns are ordinates columns used when creating a 2D
plot from data. The X-error and Y-error columns can be used in order to add error bars
to 2D plots. These flags can be changed using the Column options dialog. To reach
this dialog you simply have to double-click on the column label or to use the Column
Options... command of the Table menu.

You can select all the columns of the spreadsheet (Ctrl+A) or only some of them
by clicking on the column label while keeping the Ctrl key pressed, or by moving the
mouse over the column label. This also allows you to deselect columns.

On the selected columns you can perform various operations: fill with data, nor-
malize, sort, view statistics and finally make plots out of your data. All these functions
can be reached by right clicking on the column label or by using the Table menu.

Any other spreadsheet function: rename, duplicate, export, print, close can be
reached via the context menu (right click anywhere in the table outside the column
labels area).

You can cut, copy and paste data between spreadsheets or between a spreadsheet
and another application (Excel, Gnumeric, etc...).

You can import single or multiple ASCII files using the Import ASCII command



from the File menu. The file import options can be changed via the Set Import Op-
tions... command. Of course you can export the data from the spreadsheet to a text file
using the Export ASCII command.

1.3.2 Matrix

The matrix is a special table which is used for data which depends on two variables.
This special table is used to store data for 3D-plots. The difference between a table and
a matrix is that there is no special column nor special row for X or Y labels or values.
Nevertheless, you can specify an X-scale and an Y-scale with the Set Dimensions...
command.

# Matrixl

1 2 3 a 5 6 7 8 9 10 11 4
1371 1.340 1308 1.275 1239 1.202 1162 1121 1078 1034 09
1405 1.375 1.343 09 73 36 a7 156 1113 1.068 L.
1421 1.391 1.358 1.325 1289 1252 1213 1172 1129 1084 1.
1.437| 1.406 1.374 1340 1.305 1.267 1.228 1187 1144 1.099 1.
1451 1421 1389 1.355 1.319 1.282 1.243 1202 1159 1114 1
1464 1434 1402 1368 1333 1205 1256 1.215 1172 1127 1.
1477 1.446 1414 1380 1.345 1.307 1.268 1227 1184 1139 L.
1487 1457 1425 1391 1355 1.318 1.279 1238 1.195 1150 1.1
1496 1466 1434 1400 1364 1.327 1.288 1247 1204 1159 LI
1.503) 1473 1.441 1407 1.372 1334 1.295 1.254 1.211 1166 1.1
1508 1478 1446 1412 1.377 1339 1300 1.259 1.216 1171 11
1511 1481 1449 1.415 1.379 1342 1303 1262 1219 1174 11
1511 1481 1.449 1.415 1.379 1.342 1303 1.262 1.219 1174 11
1508 1478 1446 1412 1.377 1339 1300 1.259 1.216 1171 11
1503 1472 1440 1406 1.371 1333 1294 1253 1210 1165 11
1493 1.463 1431 1397 1361 1.324 1.285 1.244 1201 1156 1. E

J

ﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂ

|

Figure 1.3: The SciDAVis matrix

The values which are stored in a matrix can be obtained from a function of the form
z=(i,j) with the Set Values... command, i and j beeing the column and row numbers.
They can also be read from a file with the Import ASCII command which allows to
read a file in a table, then the table can be converted to a matrix with the Convert to
Matrix command of the Matrix menu.

The operations which can be done on a matrix are limited changes in number pre-
sentation and matrix size. The data of a matrix can be used to build a 3D plot with the
commands present in the Plot3d menu and in 3d plot toolbar.

1.3.3 Plot Window

The plot window is the one in which the graphic is plotted. It contains at least one layer,
which is the main container of the plot window. Each new plot can be inserted in a new
layer of this plot window, it has its own geometry and graphic properties (background
color, frame, etc). The example presented below shows a graph with two layers which
have different geometries.
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Figure 1.4: An example of SciDAVis 2D graph

Each layer can be activated by clicking on the corresponding gray button 1i2J in
the top-left corner of the window.
The elements which can be accessed by a double click in a layer are:

* the graph itself: this will open the Custom Curve Dialog. You can then add new
curves to the plot, or change the way the curves are plotted.

* The axes or the axes labels: this will open the General Plot Options Dialog. It is
used to customize the axes, the numbers and labels of the axes, and the grid.

* Any other text item, including the legend of the plot: this will open the Text
Options Dialog which allows to customize the font of the label and the frame in
which it is drawn.

1.3.4 Note

A note can simply be used to insert text (comments, notes, etc) into a project, but is
really far more powerfull than that. It can be used as a calculator, for executing single
commands and for writing scripts.

Evaluation of mathematical expressions and execution of code is done via a note’s
context menu, the Scripting menu or the convenient keyboard shortcuts.

For information on expression syntax, supported mathematical functions and how
to write scripts, see here.
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Figure 1.5: The SciDAVis Note Window

You can also change the text input method. Simple Composing Input Method is
the standard method to enter text in QT applications. Xim is the X input method, it is
the legacy system of the X window environment to support localized text input. The
default choice is the second one, it allows to enter special characters and accents from
your localised environment.

1.3.5 Log Window

This window keeps a history of all analysis which have been done in the project. This
panel contains the results of all the correlations, fittings, etc.

18.02.2006 22:58:19 Fitl:

Order 2 Polynomial fit of tablel_Y: y=a0+al*X+a2*X "2
From x=1 to x=11

al = -1.13029 +/- 0.65480

al = 2.69357 +/- 0.26424

a2 = -0.20594 +/- 0.02120

g
2
i
1
[
&

Chi™2 = 1.86085

Figure 1.6: The SciDAVis Log window

1.3.6 The Project Explorer

The project explorer can be opened/closed using the Project Explorer command from
the View menu or by clicking on the A in the file toolbar.



X | Ly fftfilter-example Mame | Type | view | size | Created il
-G band pass 5 band pass Folder 0.1 kB (128 bytes) 26.10.2006 22:18:41
Cghigh pass [=fftsignal ASTRARR WREER 07.08.2006 00:07:56
(g low pass (5 high pass I‘Tﬂmimwze window 128 bytes) 26.10.2006 00:30:53

5 low pass M;g\mize - 128 bytes) 26.10.2006 00:28:06

[signal i 5 06.08.2006 23:57:55
Emtablefftsignal (HI 0 AR 07.08.2006 00:07:56

.
5
e .
= mtablesignal 1 Delete Window i 06.08.2006 23:54:59
u Rename Window F2
&
- B Resize Window...
B
o & Print Window

Properties...

Depends on » tablefftsignal

«l I | (e

Figure 1.7: The SciDAVis Project Explorer

It gives an overview of the structure of a project and allows the user to perform
various operations on the windows (tables and plots) in the workspace: hiding, min-
imazing, closing, renaming, printing, etc... These functions can be reached via the
context menu, by right-clicking on an item in the explorer.

By double-clicking on an item, the corresponding window is shown maximized in
the workspace, even if it was hidden before.

You can organize the differents objects in folders. When selecting a folder, the
default policy is that only the objects contained in it will be showed in the workspace
window. You can also display all the objects in the subfolders if you change this policy
with the "View Windows" command to "Windows in Active Folder and Subfolders".
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Chapter 2

Drawing plots with SciDAVis

2.1 2D plots

A 2D plot is based on curves which are defined by Y values as functions of X values.
There are two ways to obtain a 2D plot depending on the way the (X,Y) values are
defined:

* You can have your (X,Y) values in a table. You need to select at least one column
as X values and one column as Y values. This is specified with the Column
Options... command. Then you can select the columns and use one command of
the Plot menu to plot the data.

* If you want to plot a function, you don’t need a table. You can use directly the
New -> New Function Plot command. This will open the corresponding dialog
box and you will be able to define the mathematical expression of your function.

* The combined way is to define a table, and then to fill in the table with the results
of functions. This can be done with the Set Column Values... command. Then
you can select the columns and use one command of the Plot menu to plot the
data.

SciDAVis will create a new plot window, and the plot will be inserted in a new layer

Once the plot is created, you can customize all the graphic items of the plot with the
commands of the Format Menu. You can add new items (text labels, lines or arrows,
new legend, images) on the plot with the commands of the Graph Menu.

2.1.1 2D plot from data.

The data must be stored in a table. There are several possibilities to insert your (X,Y)
values in the table: you can write them directly from the keyboard, or read them from
a file. Here we will use the first solution, refer to the Import ASCII command to use
the second one.

11



The first step is to create an empty project with the New -> New Project command
from the File menu, you can also use the key Ctrl-N or the [ icon from the File
toolbar. Then create a new table with the New -> New Table command from the File
menu or with the Ctrl-T or with the icon from the File toolbar.

At its creation, the table has two column (one for X and one for Y) and 32 rows.
You can add rows and columns by selecting a row or a column and using the right
button of the mouse, you can also modify the number of rows and columns with the
Rows command and Columns command from the Table menu. You enter your values,
and obtain this table:

## tablel

1[x] 2[¥]
1] 1 4.2
2. 2.2 31
EN 3 1.7
2 | 45 21
5 | 5.2 3.2
6 | 7.1 1.2
(7 | 8.2

Figure 2.1: A simple 2D plot: the table.

The you have to select the two columns, and build your plot (here a simple 2D
scatter) with the Scatter command from the context menu, or by clicking on the corre-
sponding .*" icon from the Plot toolbar or with the Scatter command from the Plot
menu. A plot is created which uses the default options for all elements. You can cus-
tomize these default options with the preferences dialog. With the default options, you
obtain the following plot:

12
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Figure 2.2: A simple 2D plot: the default plot.

You can then customize your plot. By double clicking on the points, you open the
Custom curves dialog which is used to modify the symbols. Then a double-click on
the axes opens the general plot options dialog, and you can change the scales, the fonts
for the axes labels, etc. You can also add grid lines on X or Y axes, etc. Finally, a
double click on each text item (X title, Y title, plot title) allows to change the text and
the presentation of these elements. The final plot is:

B2 graph2 |
&3]
Simple 2D plot (from (X,Y) values)
5_
3] &
' hd
3 17
N <
> 0
-
7] ®
-2 - ¢
7] ¢
-4 T T T T T T T 1 T T T
0 1 2 3 4 5 6 7 8 9
X values

Figure 2.3: A simple 2D plot: the plot finished.

Finally, you have to save your project in a ’.sciptj’ file with the Save Project com-
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mand from the File menu or with the Ctrl-S or with the @ icon from the File toolbar.
Depending on your application, you can export your plot to a standard image file with
the command Export Graph -> Current command from the File menu (or with the Alt-G
keycode).

There are several types of plots which can be built from a table. They are presented
in the Plot menu

It is possible to use up to four axes for the data:

[ Graph1 [EEES]
1]

10

o

@

~ 60

IS

40

%)

~ 20

Y1
Lo by by v b by

o

D;
-
A_-
o -

Figure 2.4: A 2D plot with two Y axis.

In addition to the customization which has been already described, the axes which
are used for each curve were defined with the Custom Curves Dialog, and two arrows
were added with the Draw Arrow command.

¥ Plot details x
£ 15 Graph? Axes | Line | Symbol
=[] Layer!
B3 Tablel: Rz Aftach curve to:
; Tahle1: RZD JAREm)
. [ Tahlel: RZD20), 200 4(vEm) * fis [Elm‘[um ¢]
y Bodis |Left 2]
Plot type [Lme + Symbol :] [ Worksheet ] [ oK l [ Cancel ] [ Apply ] [Elut Associations

2.1.2 2D plot from function.

There are two ways to obtain such a plot: you can plot directly a function or fill a table
with the values calculated from this function before doing a plot in the classical way.
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2.1.2.1 Direct plot of a function.

If you just want to plot a function, you can use the New -> New Function Plot command
from the File menu or with the Ctrl-F or with the ¥ icon from the File toolbar.

This command will open the Add Function Curve dialog. You can then enter the
expression of your mathematical function, the X range used for the plot, and the number
of points used in this X range. Beside classical Y=f(X) functions, parametric and polar
functions can be defined.

Add function curve = [ Graph3 =
1
Curve type [Funztinn :l Title
2
e 3
)= '
! u,s—f
i
From x= [D ] '-os—z
To %= [au ] I
Points | 300 S s
23
ClearFunEtiDnH o ][ - l ‘\...L\H.‘|n..\\‘|5....2‘0\...22.”.;0'
X Axis Tite

Figure 2.5: Direct plot of a function.

2.1.2.2 Filling of a table with the values of a function.

If you just want to work not only with the plot but also with the data, you can create
a new table as explained in the previous section. Then you can fill this table with the
values of a function with the Set Column Values... command.

To obtain the same plot as in the previous example, you need to create a new table
(key Ctrl-T), then select the first column and use the command Set Column Values...
command from the context menu, or from the Table menu. The row number symbol is
i, so you can enter the function expression i//0 and use 300 rows.
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Figure 2.6: Function plot: filling of the X column.

The second step is to select the second column and use the same command. The
expression is a function of the X values, that is the first column named col(1).

g tiPlot - Set column valites =) &
10x] 2[¥]

1| B o.611792] st For row (i) [T to [300
=] Vatue ot .
El (]  o0.749116 | absD ¥ || Addfunction |
a ]
o Lot % (_ Addcoumn |
Oom
7| o7 IREEER ==l || addcel |
el n‘a col(2)=
9 | 0.9 1.05083 sin(col(1))+cos(col(1)/3+1)] i ox 1))
(10 | 1 1.07671
11 | W] 1.09397] Apply
2
= 1‘3 Cancel
(14 | 1.08939 B

Figure 2.7: Function plot: filling of the Y column.

Once the table is ready, you just have to build the plot as explained in the previous
section.

2.2 3D plots

3D plot are generated from data defined as Z=f(X,Y). As for 2D plots, there are two
ways to obtain a 3D plot depending on the way the (X,Y,Z) values are defined:

* You can have your Z values in a matrix. SciDAVis will consider that all the data
present in the matrix are Z values, and the X and Y values can be defined as a
function of the columns and rows numbers.

The data in the matrix can be entered in several ways:
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— one by one from the keyboard,
— by reading an ascii file in a table and converting the table into a matrix,
— by setting the values with a function.
 If you want to plot a function, you don’t need a matrix. You can use directly
the New -> New Surface 3D Plot command. This will open the corresponding

dialog box and you will be able to define the mathematical expression of your
function.

There are several kinds of 3D plots which can be selected, see the Plot3d menu
section of the reference chapter for a list of the availables plots.

1 graphs CI-I<

Figure 2.8: Example of a 3D Plots.

The 3D plots use OpenGL so you can easily rotate, scale and shift them with the
mouse. Via the 3D plot settings dialog or via the Surface 3D Toolbar you can change
all the predefined settings of a three dimensional plot: grids, scales, axes, title, legend
and colors for the different elements.

There are several types of plots which can be built from a matrix. They are pre-
sented in the Plot3d menu

2.2.1 Direct 3D plot from a function

This is the simplest way to obtain a 3d plot. It is done with the New -> New Surface
3D Plot command from the File menu or directly with the Ctrl-Alt-Z. This will open
the folowing dialog box:
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Define surface plot o x
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Figure 2.9: Definition of a new surface 3D plot

You can enter the function z=f(x,y) and the ranges for X, Y and Z. Then SciDAVis
will create a default 3d plot:

(& Graphl =) L] (%)

Figure 2.10: The 3D surface plot created by default

You can then customize this plot by opening the Surface plot options dialog. You
can modify the axis ranges and parameters, add a title, change the colors of the different
items, and modify the aspect ratio of the plot. In addition, you can use the different
commands of the 3d plot toolbar to add grids on the walls or to modify the style of the
plot. After some modifications, you can obtain the following plot:
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@ 1 - plot from function L=l (2] (%]

Figure 2.11: The 3D surface plot after customizations

If you want to modify the function itself, you can use the surface... command
which can be activated from the context menu with a right click on the 3D plot. This
will re-open the define surface function dialog box.

2.2.2 3D plot from a matrix

The second way to obtain a 3D plot is to use a matrix. Therefore, the first step is to fill
the matrix.This can be done by defining a function.

The New -> New Matrix command create a default empty matrix with 32x32 cells.
Then use the Set Dimensions... command to modify the number of rows and columns
of the matrix. This dialog box is also used to define the X and Y ranges.

Matrix Dimensions olx

Dimensions

Riows ||1 m

H Columns [ww Ie]

Coordinates

¥ (Calumng)

W (Rows)

First |-5

1=

]

Last [5

| 6

J

Then use the Set Values... command to fill the cells with numbers. The ranges of X
and Y defined in the previous step are not known by this dialog box, then the function is
defined with the row and column numbers (i and j) as entry parameters (see the section
set-values for details).

The other way to obtain a matrix is to import an ASCII file into a table with the
Import ASCII -> Single File... command from the File menu. The table can then be
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transformed in a matrix with the command Convert to Matrix command from the Table
menu.

You can then use this matrix to build a 3D plot with one of the command of the Plot
menu.

2.3 Multilayer Plots

The multilayer windows can contain multiple plots (layers) with different characteris-
tics. Each layer has a corresponding button, which displays a number and is pressed
when the layer is the currently active layer. There is only one active layer at a time, and
the plot tools (zoom, cursors, drawing tools, delete and move points) can only operate
on this layer. Each plot can be made active by clicking on it or on its corresponding
button.

To arrange the layers use the Arrange Layers dialog. You can add or remove layers
with the Add Layer command and Remove Layer command or copy/paste layers from
one multilayer window to another. All these functions can be reached via the Graph
menu, by using the Plot toolbar or via the context menu (right click in the multilayer
window anywhere outside a plot area).

You can resize and move a layer using the Layer geometry dialog. You can also
arrange and resize the plots by hand. A whole plot can be moved by drag and drop:
click on the plot and keep the left mouse button pressed.

By keeping the Shift key pressed and dragging the border of a plot you can scale
a plot as needed. When moving the mouse over the borders of a plot, you will see the
corresponding arrows.

You can also use the mouse wheel in order to resize the layers: keeping the Ctrl
key pressed and scrolling will resize the hight of the plot canvas, while keeping the Alt
key pressed and scrolling will resize its width. By keeping the Shift key pressed and
scrolling you can resize the plot in both dimensions.

2.3.1 Building a multilayer plot panel

This is the simplest way to obtain a multilayer plot. It can be used if you want to build
a panel of plots with a simple arrangement: 2 plot in a row or in a column, or 4 plots in
2 rows and 2 columns.

You can select two columns with Y-values in a table, and then use one of the Panel
commands in the Plot menu. SciDAVis will create a panel of plots in which the size of
the different elements of each plot are synchronized.
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You can then customize the two plots, if you want to change the arrangement of
the panel, you can use the Arrange Layers command from the Graph menu. It must be
reminded in this case that each plot is in a layer with a surface which is the half or the
quarter of the window surface area. So, if you want to share an element between the
two plots (for example a text label), you need to add it in a new layer (see the Add Text
command for more detaile).

2.3.2 Building a multilayer plot step by step

If you need to build a more complex multilayer plot, you can define it step by step.
The first step is to build your first plot, for example from two columns of a table.
We obtain a standard plot window:

witablez M B BN 2 graphs CI=Ix]
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1 Title
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Then, select the plot window and use the Add Layer command from the Graph
menu. This will activate the Add Layer dialog. If you choose "Guess" you will obtain
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a panel with two columns, if you choose "corner" you will obtain two superposed
layers, you can then modify these two layers.
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If you want to build a panel with two rows, you can use the Arrange Layers com-
mand to convert this panel.
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Then select the second void plot and use the Add/Remove Curves... command to
select the Y-values from one of the tables of the project.
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After this, you can customize your plot. At the end, the modifications done on the
axis or on the axis labels may have modified the geometry of the two plots. You can
synchronize again the two plots by applying again the Arrange Layers command.
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Chapter 3

Command Reference

The active items in the menus depend on the active window in the project. If the active
window is a spreadsheet, then all the items linked to table functions are enabled and
the others are automatically disabled.

3.1 The File Menu

These commands can also be done by clicking on the New Project icon from the File
Toolbar

File-> New ->

New -> New Project (Ctrl-N) Creates a new SciDAVis project file. If a project
is open and saved, it will be closed. If a project is open is not saved, a
dialog will be open to ask if the current project has to be saved.

New -> New Table (Ctrl-T) Creates a new spreadsheet into the project. This
empty table will have 30 rows and 2 columns. This number of rows and
columns can be changed with the Rows command and Columns command
of the Table menu.

# table3
1[x]

“’J*‘I"‘I“J“I“I“ﬂ

d

The properties of each column (format of numbers, width, etc) can be mod-
ified by the Column Options... command of the Table menu. See the table
section for more details.
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New -> New Matrix Creates a new Matrix into the project. The empty matrix
will have 32x32 cells, these dimensions can be changed by the Set Dimen-
sions... command of the Matrix menu

£ Matrix2

FMEENEE

See the matrix section for more details.

New -> New Note Creates a new note window in the project. A note is a simple
text window which can be used to add comments to the current project.

&) Notel

This plet is an example of the
errorbar commands

It shows also the use of the non
linear curve fit

New -> New Graph Creates a new empty 2D plot in the project. This default
graph is just a framework in which you can add curves with the Add/Re-
move Curves... command.

&8 graphl 1=I=]
&)
Title
1000
o |
800
o2
-
= 600
2
X 400
>
200
o7
0 200 400 600 800 1000
X Axis Title

New -> New Function Plot (Ctrl-F) Opens a dialog allowing to create a plot
by specifying an analytical function. See the 2D plot section of the tutorial
for a general overview of this function.

This function can be defined in cartesian, parametric or polar coordinates,
see the Add Function... command for more details.

New -> New Surface 3D Plot (Ctrl-Alt-Z) Opens a dialog allowing to create a
3D plot by specifying an analytical function. Only cartesian coordinates
are availables. See the 3D plot section of the tutorial for more detail on this
function.
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File -> Open (Ctrl-O) Opens an existing SciDAVis project file (default file extension
.sciprj). If your project has been save in a compressed format, you must select
the .sciprj.gz file format.

This command can also be used to open projects which have been built with the
Origin software.

File-> Recent Projects Opens a list of the most recently used SciDAVis project files.
You can open one of these files by selecting it from the list. If the file doesn’t
exist anymore an error message will pop-out and the file will be automatically
deleted from the list.

File-> Open Image File This command loads an image file in a SciDAVis project.
This image can be resized and then inserted in another 2D plot. It is in this case
similar to the Add Image command. This image can also be used to generate an
intensity matrix (see the Import Image... command).

File-> Import Image... With this command, an image is loaded in the SciDAVis project
and converted to an intensity matrix. For each pixel, an intensity between 0 and
255 is computed from the intensities of the three colors red, green and blue.

& Graphs B

fGraphd - home/..._ 0O x

This example shows the 3D plot which has been drawn from the matrix obtained
with the SciDAVis logo.

File-> Save Project (Ctrl-S) Saves the actual project. If the project hasn’t been saved
yet ("untitled" project), a dialog will open, allowing to save the project to a spe-
cific location.In a project file all settings and all plots are stored in ASCII format.

If the project include large tables, it may be usefull to save the project in a com-
pressed file format. The free zlib library is used to build files in gzip formats (

.sciptj.gz ).

File-> Save Project as... Saves the actual project under a file name different from the
current one.

File -> Open Template Opens an existing template SciDAVis plot file (.qpt). This
command will create a new empty plot with the same graphical parameters (win-
dow geometry, fonts, colors, etc).
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The first figure is the initial plot saved as a template, and the second one is the
empty plot created by the Open Template.
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You just have to add curves with the Add/Remove Curves... command, but the
style used to draw the curves is not kept in the template.

File -> Save as Template Save the active plot as a SciDAVis template file (.qpt). In
this template, the graphical parameters of the plot, together with the text labels
(axis, etc) are restored, but the style used to draw the curves and the scales are
not saved.

File -> Export Graph The plot can be exported into several different image formats.
You can define some parameters to customize your image file by checking the
show options check box. Depending on the chosen image format, the available
options are not the same.

For bmp, pbm, jpeg, xbm, pgm, ppm image formats, the only option is the quality
of the image, this parameter between 0 and 100% defines the compression ratio.
The higher it is, the best the quality is but the larger the file is.
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For png and xpm, you can choose to use a transparent background.
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For eps file format, the option dialog is different. The parameters availables are:
the size of the paper which is used to draw the plot, and the orientation of the
paper sheet. The plot aspect ratio will be adapted to the sheet size and orientation.

In addition, you can define the resolution. The default value is 84. If you increase
this parameter, the quality of the graphic elements will be better (but the overall

size of the plot will be unchanged).
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The last format which can be selected is the Scalable Vector Graphic format.
With this format, the files can be modified in vector drawing software such as
Sodipodi.

Export Graph -> Current (Alt-G) Here you have the possibility to save the
active plot under different image formats.

Export Graph -> All (Alt-X) Here you have the possibility to save all plots of
the project under different image formats.

File-> Print (Ctrl-P) Prints the active plot. A print dialog is opened where you can
select the printer, different paper sizes, etc.

File-> Print All Plots Prints all plots of the projects. A print dialog is opened where
you can select the printer, different paper sizes, etc.

File -> Export ASCII Opens the Export ASCII dialog allowing to save the data from
the active spreadsheet to an ASCII file.

File -> Import ASCII -> The options for the importation of ASCII datas are set by
the Import dialog which is activated by the Set Import Options... command.

Import ASCII -> Single File... Imports a single ASCII file into the project by
creating a new spreadsheet storing the data from the file.

Import ASCII -> Multiple Files... Imports several ASCII files into the project
by creating a new spreadsheet for each file. The new spreadsheets are au-
tomatically arranged in a cascade style.

You can choose to put each data file in a separate table, or join all the data
files in one table. Remind that if you choose this last solution, only one
column can be selected as X values.

Set Import Options... Opens the Import dialog allowing to change import op-
tions like: the column separator or the number of first lines to be ignored.

File -> Quit (Alt-F4) Closes the application. You will be asked wether you want to
save your last changes or not.
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3.2 The Edit Menu

Edit -> Undo (Ctrl-Z) Restores the last modified table at the state it had after the last
"Save Project" operation. Not available for plot windows.

Edit -> Redo (Ctrl-R) Restores the modifications in a table after a "Undo" operation.
Function not available for plot windows.

Edit -> Cut Selection (Ctrl-X) Copies the current selection to the clipboard and deletes
the selection. It currently works for spreadsheets and for 2D plots objects.

Edit -> Copy Selection (Ctrl-C) Copies the current selection to the clipboard. It cur-
rently works for spreadsheets and for 2D plots objects.

Edit -> Paste Selection (Ctrl-V) Pastes the content of the clipboard to the active win-
dow.

Edit -> Delete Selection () Cleares the current selection. It currently works for spread-
sheets and for 2D plots objects.

Edit -> Delete Fit Tables Each time yo do a fit of your data with some mathematical
model, a new table is created to put the results of the fit (i.e. the values computed
by the model). These tables can be used to plot comparisons of experimental and
fitted values.

If you have done several fitting tentatives, a number of unused table may be
present in your project. This command allows to remove the results of all the
differents fits that you have tested.

Edit -> Clear Log Informations Deletes from the project file all the history informa-
tion about the analysis operations performed by the user. The log panel is then
empty.

3.3 The View Menu

View -> Plot Wizard (Ctrl-Alt-W) Opens the Plot Wizard dialog.

View -> Project Explorer (Ctrl-E) Opens/Close the Project Explorer, which gives an
overview of the structure of a project and allows the user to perform various
operations on the windows (tables and plots) in the workspace.

View -> Results log Opens/Close a panel displaying the historic of the data analysis
operations performed by the user.

View -> Preferences... Opens the Preferences dialog.
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3.4 The Graph Menu

This menu is only active when a plot window is selected.

Graph -> Add/Remove Curves... (Alt-C) Opens the Add/Remove Curves... dialog,
allowing to easily add or remove curves from the active plot layer. This dialog
can also be used to modify a curve which is already plotted by changing the
columns which are used as X or Y values.

Graph -> Add Error Bars... (Ctrl-B) Opens the Add Error Bars... dialog. You can
add error bars on X and/or on Y values on an existing plot.

Graph -> Add Function... (Ctrl-Alt-F) Opens the Add Function... dialog. This com-
mand allows to add a a new curve on an existing plot.

Graph -> New Legend (Ctrl-L) Adds a new legend object to the active plot layer.
You can have more than one legend on a plot. These legends can then be cus-
tomized by double clicking on a given legend.

Graph -> Add Text (Alt-T) Opens a dialog allowing you to select whether the text is
to be added to the active plot layer or on a new layer. The cursor changes to an
edit text cursor. Next, you must click in the plot window to specify the position
of the new text box. A text dialog will pop-up allowing you to type the new text
to be displayed and all its properties (color, font, etc...)

Graph -> Draw Arrow (Ctrl-Alt-A) Changes the active layer operation mode to the
drawing mode. You must click on the layer canvas in order to specify the starting
point for the new arrow, and then click once more to specify its ending point. You
can edit the new arrow using the Arrow dialog. You can swith back to the normal
operating mode by clicking the "Pointer" icon in the Plot toolbar.

Graph -> Draw Line (Ctrl-Alt-L) Changes the active layer operation mode to the
drawing mode. You must click on the layer canvas in order to specify the starting
point for the new arrow, and then click once more to specify its ending point. You
can edit the new arrow using the line dialog. You can swith back to the normal
operating mode by clicking the "Pointer" icon in the Plot toolbar.

Graph -> Add Time Stamp (Ctrl-Alt-T) This command is used to add a special la-
bel in the current plot which contains the current date and time. The properties
of this label can be customized like any other label that is added by the Add Text
command.

A timestamp label is not modified if the plot is modified, saved, etc.
Graph -> Add Image (Alt-I) Opens a file dialog allowing you to select an image to
be added to the active plot layer. Only a link to the image file will be saved into

the project file and not the image itself. The new image is added to the left-top
corner of the layer and can be moved by drag-and-drop.
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Graph -> Add Layer (Alt-L) Opens a dialog allowing you to select whether the new
layer is to be added to the left-top corner of the plot window or to a best-guess
position (based on a layer positioning algorithm in columns and rows).

Graph -> Remove Layer (Alt-R) Deletes the active layer and prompts out a question
dialog allowing you to choose whether the remaining layers should be automati-
cally re-arranged or not.

Graph -> Arrange Layers (Alt-A) Opens the Arrange layers dialog, allowing you to
custom the layout of the active 2D plot window.

3.5 The Plot Menu

This menu is active only when a table is selected. These commands allow to plot the
data selected in the active table.

Line Plots the selected data columns in the active table window using the "Line" style.
This command can also be activated by clinking on the .~ icon of the Table
toolbar. Once the plot is created, the drawing of the data series can be customized
with the Custom curves dialog.
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Scatter Plots the selected data columns in the active table window using the "Scatter”
style. This command can also be activated by clinking on the .*" icon of the
Table toolbar. Once the plot is created, the drawing of the data series can be
customized with the Custom curves dialog.
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Line+Symbol Plots the selected data columns in the active table window using the
"Line + Symbol" style.This command can also be activated by clinking on the
~ icon of the Table toolbar. Once the plot is created, the drawing of the data
series can be customized with the Custom curves dialog.
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Special Line+Symbol -> Vertical Drop Lines Plots the selected data columns in the
active table window using the "Vertical drop lines" style. Once the plot is
created, the drawing of the data series can be customized with the Custom
curves dialog.
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Spline Plots the selected data columns in the active table window using the
"Spline" style. Once the plot is created, the drawing of the data series
can be customized with the Custom curves dialog.
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Vertical Steps Plots the selected data columns in the active table window using

the "Vertical Steps" style. Once the plot is created, the drawing of the data
series can be customized with the Custom curves dialog.

Horizontal Steps Plots the selected data columns in the active table window
using the "Horizontal Steps" style. Once the plot is created, the drawing of
the data series can be customized with the Custom curves dialog.
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Columns Plots the selected data columns in the active table window using the "Columns"
style, that is vertical bars.
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Rows Plots the selected data columns in the active table window using the "Rows"
style.
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Area Plots the selected data columns in the active table window using the "Area" style.
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Pie Creates a 2D Pie plot of the selected column in the active table window (only one
column allowed).
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Vectors XYXY Creates a vectors plot of the selected column in the active table win-
dow. You must select four columns for this particular type of plot. The two first
columns give the coordinates for the starting points of the vectors, the two last
columns giving the information regarding the end points.
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Vectors XYAM Creates a vectors plot of the selected column in the active table win-
dow. You must select four columns for this particular type of plot. The two first
columns give the coordinates for the starting points of the vectors, the two last
columns giving the angle (in radians) and the magnitude of the vectors.

Statistical Graphs -> Statistical plot will not give a direct drawing of the data selected

in the table, but they will give a representation of the frequency distribution of
the Y-values.

Statistical Graphs -> Box Plot Creates a box plot of the selected data columns
in the active table window. This type of plot is used to give a graphical
representation of the some classical parameters of the frequency distribu-
tion such as the mean of data, the min and max values, the position of the
95 and 5 percentiles, etc. The choice of the statistical parameters and the
graphical parameters can be modified with the Custom curves dialog.
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Statistical Graphs -> Histogram Creates a frequency histograms of the selected
data columns in the active table window. The default binning uses 10 steps
between the max and the min of Y-values. This can be modified with the
Custom curves dialog.
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With this command, a frequency distribution is computed from your data.
If you want to draw an histogram directly from values, use the Bars.

Statistical Graphs -> Stacked Histogram Creates vertically stacked layers dis-
playing the histograms of the selected data columns in the active table win-
dow (one histogram per layer) See the Panel -> Vertical 2 Layers command
for more details.

Panel -> These commands can be used to obtain quickly some classical arrangements
of multiple plot.

Panel -> Vertical 2 Layers Creates 2 vertically stacked layers displaying the
selected data columns in the active table window (one curve per layer).

Panel -> Horizontal 2 Layers Creates 2 horizontally stacked layers displaying
the selected data columns in the active table window (one curve per layer).

Panel -> 4 Layers Creates 4 layers on a 2x2 grid, displaying the selected data
columns in the active table window (one curve per layer).

Panel -> Stacked Layers Creates vertically stacked layers displaying the se-
lected data columns in the active table window (one curve per layer).

Data -> Plot 3D -> Plot 3D -> Ribbons Makes a 3D plot of the selected data column
in the active table window (only one column allowed) using the "Ribbon"
style.

#% graph3
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Bars Makes a 3D plot of the selected data column in the active table window
(only one column allowed) using the "3D Bars" style.

#5 graph4 |28 x] I

Scatter Makes a 3D plot of the selected data column in the active table window
(only one column allowed) using the "3D Dots" style. The 3D point symbol
style can be changed via the 3D Plots Settings dialog.

#8 graphs |_J=| I

With scatter plots, you can choose the kind of graphic item which is used
to plot the data points. The example above is done with cross hairs, but
you can also select points or cones. This can be done either with the corre-
sponding icons of the 3d plot toolbar (respectively ## % and & for
cross-hairs, dots and cones) or with the custom-curves dialog.

Plot 3D -> Trajectory Makes a 3D plot of the selected data column in the active
table window (only one column allowed) using the "3D Line" style. The
line width and color may be changed via the 3D Plots Settings dialog.
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3.6 The Plot 3D menu

This menu is only active when a matrix is selected.

3D Wire Frame Makes a 3D plot of the selected matrix using the "3D mesh" style.

& mesh L=f 121X

3D Hidden Lines Makes a 3D plot of the matrix using the "3D mesh" style with hid-
den lines.

"
7 hiddenline |24 %

3D Polygons Makes a 3D plot of the matrix using the "3D polygons" style.
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3D Wire Surface Makes a 3D plot of the matrix using the "3D polygons" style with
the mesh drawn.

Bars Makes a 3D plot of the selected data column in the active table window (only
one column allowed) using the "3D Bars" style.

@ bars L=l 1=

Scatter Makes a 3D plot of the selected data column in the active table window (only
one column allowed) using the "3D Dots" style. The 3D point symbol style can
be changed via the 3D Plots Settings dialog.
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Contour+Color Fill Makes a color map plot of the data in the active matrix window.
The contour lines and the colormap settings may be changed by clicking on the
plotting area, this will active the Contour Options Dialog.

Countour Lines Makes a contour plot of the data in the active matrix window. The
contour lines and the colormap settings may be changed by clicking on the plot-
ting area, this will active the Contour Options Dialog.
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Gray Scale Map Makes a gray map plot of the data in the active matrix window. The
contour lines and the colormap settings may be changed by clicking on the plot-
ting area, this will active the Contour Options Dialog.

IS
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3.7 The Data Menu

This menu is active only when a plot is selected.

Data -> Disable tools When you are using a command which modify the pointer such
as the Data Reader, this command can be used to exit this special mode, and go
back to the normal pointer behaviour.

Data -> Zoom in (Ctrl-+) Switches the active plot layer to the zoom mode. The
mouse cursor shape changes to a magnifying lens only inside the active plot
canvas. You can select a window in the current plot which will be used as the
new plotting window.

Data -> Zoom out (Ctrl--) This command cancel the previous zooming, a history of
the zoom is kept so that you can do multiple zoom out commands.

Data -> Rescale To Show All (Ctrl-Shift-R) Rescale the active plot layer after a zoom
operation.

Data -> Data Reader (Ctrl-D) Shows a red cross cursor and opens the Data Display
toolbar giving easy and fast access to the values of the data points. You can select
data points by moving the cursor with the Left and Right arrow keys or faster by
clicking on them with the mouse. You can navigate through the curves on the
plot layer using the Up and Down arrow keys.

Data -> Select Data Range (Alt-S) Shows two rectangular cursors that can be used
for selecting the data range when performing analysis operations. The mouse
cursor shape changes to a rectangular target only inside the active plot canvas.
The active cursor is red, the other is black.You can move the active cursor with
the arrows keys while keeping the Ctrl key pressed or faster by clicking on a
curve point. You can change the active cursor using the Left and Right arrow
keys. You can navigate through the curves on the plot layer using the Up and
Down arrow keys.

Data -> Screen Reader Opens the Data Display toolbar and changes the mouse cur-
sor shape to a small cross target. By keeping the left button pressed and moving
the mouse you can view the coordinates of the cursor with respect to the axes of
the active plot layer.
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Data -> Move Data points (Ctrl-Alt-M) Allows you to modify the position of data
points in the active plot layer by simple drag-and-drop. It opens the Data Display
toolbar, for a better visualisation of the new coordinates. The changes you make
automatically modify the data into the corresponding tables and all the plots
depending on those data sets.

Data -> Remove Bad Data Points (Alt-B) Allows you to remove data points from
the active plot layer by double-clicking on them. The coordinates of the points
selected for removal are shown in the Data Display toolbar. The changes you
make automatically modify the data into the corresponding tables and all the
plots depending on those data sets.

3.8 The Analysis Menu

The commands which are available in this menu are not the same if a table or a plot is
selected.

3.8.1 Commands for the analysis of data in tables

Statistics on Columns Creates a new table providing basic statistical information about
the selected columns in the active table: average, variance, standard deviation,
max value, etc...

sinx[Y]
0.1 0.0998334

cosx[Y]
0.985004

random[Y]
0.382642

1
2 02 0198669 0980067 0 568351
3 | 0.3 0.29552 0.955336 1
a | 04 0.389418 0.921061 0.371586
5 | = tablel-stat - Statistics of tablel =l &) %]
6 || colName[X] Rows[Y] |MeanY] | StandardDev[Y] Variance[Y] Sum[¥] |iMa:
7|4 sinx [1:30] 066513 0289722 0083939 19.9539
8 | 3/ cosx [1:30] 0.0138343 0701921 0492693 0415029
3 random [1:30] 0.427571 0287158 0.0824508 12.8271
- I J -

You can select several columns in one table, one line will be created for each
column. You can’t select columns in different tables to obtain one single table of
statistics.

Statistics on Rows Creates a new table providing basic statistical information about
the selected rows in the active table: average, variance, standard deviation, max
value, etc...

See the Statistics on Columns command command for more details.

Sort Column Sorts the columns selected. If more than one column is selected, you
can sort them:

* separately: each column will be sorted in ascending or descending order
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* together: the column selected as leading column will be sorted in ascending
or descending order, and the others column selected will be sorted in order
to keep the rows unchanged.

Sorting Options

Sortcolumns | Together &
-

Leading column | RZDZ

Sort Table This is the same command as Sort Column but it operate on all columns of
the active table.

Normalize Normalizes the columns selected, that is modify the data in order to obtain
arange of O to 1. All columns selected are normalized separately. This command
doesn’t create new normalized columns but replace the values of the selected
columns.

Normalize -> Columns Normalizes the selected column.

Normalize -> Table Normalizes all the columns of the table, it is not a global
normalization of all values of the table: each column is normalized sepa-
rately.

FFT... Computes a direct or inverse Fast Fourier Transform. The parameters used can
be set with the FFT dialog. See the fft section of the Analysis chapter for more
details.

Correlate Does a cross-correlation of the two columns which are selected. See the
correlate section of the Analysis chapter for more details.

Convolute Does a convolution of the two columns which are selected. The first one
being the response and the second the signal. See the convolution section of the
Analysis chapter for more details.

Deconvolute Does a deconvolution of the two columns which are selected. The first
one being the response and the second the signal. See the deconvolution section
of the Analysis chapter for more details.

Non Linear Curve Fit... (Ctrl-Y) Opens the Non-linear Fit dialog, allowing you to
choose the curve to fit, the algorithm and the tolerance, the number of iterations
to be performed, and to type the analytical function to use, the names of the
fitting parameters and their initial guessed values. See the Non Linear Curve Fit
section of the Analysis chapter for more details.
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3.8.2 Commands for the analysis of curves in plots

The following items are enabled only if the active window is a 2D Multilayer Plot
Window. If the active plot layer contains more than one curve, and the Data Range
Selectors are not enabled, a dialog window will pop-out allowing you to select the
curve you want to analyse.

In most of the cases (except for integration), a new red curve is added to the active
plot layer and a a new table containing the data used to plot this curve is added to the
workspace. Useful information about the operation performed will be showed in the
Results Log display.

The commands FFT... and Non Linear Curve Fit... are presented in the Table
Analysis Menu.

Analysis -> Differentiate Creates a new plot displaying the resulting curve of the nu-
merical differentiation. The computation of the derivative is done by centered
finite diferences.

This command creates a new table which contains one column for X-values and
one column for derivatives of Y-values. It also creates a new plot of the deriva-
tive.

Analysis -> Integrate... Opens the Integration dialog, allowing to choose the curve to
integrate and the integration method.

This command can’t be used to obtain a cumulative curve from a selected curve,
it can only compute the integral of the data between two limits. The result is
given in the Log Panel.

Analysis -> Smooth .

Savitski-Golay This command performs a smoothing of the selected curve with
the Savitzky-Golay method. The formula used to smooth the curve defined
by the points y;=f(x;) is:

The fj values are computed by fitting the data points to a polynome, they
depend on the number of points used for the smoothing of the curve and the
order of the polynome. Compared to the moving window average method,
the advantage of this smoothing method is that the values of extrema are not
truncated. The dialog allows to specify the curve which will be smoothed,
the value of the order of the polynome, the number of data points used for
the polynomial fit before and after each point and the color used to draw
the smoothed curved. A new table will be created to store the data points
Xi, Zj.
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Figure 3.1: The Smooth -> Moving Window Average... dialog.

Moving Window Average... This command performs a smoothing of the se-

lected curve with the moving window average method. The formula used
to smooth the curve defined by the points y;=f(x;) is:

1
== 2 ¥

M j=inin

The greater the number of points 7, the smoother the resulting curve z;=f(x;)
is. The dialog allows to specify the curve which will be smoothed, the value

of n and the color used to draw the smoothed curve. A new table will be
created to store the data points x;, z;.
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Figure 3.2: The Smooth -> Moving Window Average... dialog.

Analysis -> FFT Filter Low Pass... This command allows to filter the high frequen-
cies of a signal. See the filtering section for more details. A dialog box

will be opened in which you can select the curve to filter and the cut-off
frequency of the filter.

Filter options

- T
Filter curve Tahle1_2 S

Cloge
Freguency cutoff (Hz)

Figure 3.3: The FFT Filter -> Low Pass... dialog.

This command creates a new table with the filtered data, and a new curve
will be added on the current plot.
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High Pass... This command allows to filter the low frequencies of a signal. See
the filtering section for more details. A dialog box will be opened in which
you can select the curve to filter and the cut-off frequency of the filter.

Filter options

. e o
Filter curve Table1_2 =

Close
Fraguency cutoff (Hz) 0

Figure 3.4: The FFT Filter -> High Pass... dialog.

This command creates a new table with the filtered data, and a new curve
will be added on the current plot.

Band Pass... This command allows to filter the low and high frequencies of a
signal. See the filtering section for more details. A dialog box will be
opened in which you can select the curve to filter and the cut-off frequency
of the filter.

Filter options olx
o3
Filter curve: Tahlel_7 S
Close
Low Frsquency () [ gee ]
High Frequency (Hz) |3.5
Add DC Offget
Colar B red S

Figure 3.5: The FFT Filter -> Band Pass... dialog.

This command creates a new table with the filtered data, and a new curve
will be added on the current plot.

Band Block... This command allows to keep the low and high frequencies of
a signal. See the filtering section for more details. A dialog box will be
opened in which you can select the curve to filter and the cut-off frequency
of the filter.
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Filter options olx

T
Filter curve: Tahlel_7 S
Close
Low Fraquency (Hz) |0
High Frequency (Hz) |0
Suhstract DC Offset
Colar B red S

Figure 3.6: The FFT Filter -> Band Block... dialog.

This command creates a new table with the filtered data, and a new curve
will be added on the current plot.

Analysis -> Interpolate... Performs an interpolation. The curve must have enough
data points to compute the interpolated points, if not a warning message will be
prompted out.

The methods available to perform the interpolation are Linear (the curve must
contain at least 3 points), Cubic Spline (the curve you analyse must contain at
least 4 points, if not a warning message will be prompted out, Non-rounded
Akime spline (the curve you analyse must contain at least 5 points). See the
Analysis chapter for a comparison of the differents methods.

b Interpolation Options olx
s
hdake curve from | Tahlel_g2 S
Close

From Xmin

Foints 1000
1
7

Ta Xmax

Calor o red =

Figure 3.7: The Interpolate... dialog.

This command creates a new curve on the current plot, and a new table.

Analysis -> FFT... Performs a forward or inverse FFT transform of the selected curve.
The parameters used can be set with the FFT dialog.
The inverse FFT transform of a forward transform will result in a data set iden-
tical to that used for the forward transform.

Analysis -> Fit Linear Performs a linear fit of the selected curve. The results will be
given in the Log panel
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Analysis -> Fit Polynomial... Opens the Polynomial Fit dialog, allowing you to choose
the curve to fit, the order of the polynomial function to use, the number of points
of the resulting curve and the abscissae limits for the fit.

Analysis -> Fit Exponential Decay
First Order... Opens the Exponential Fit dialog, allowing you to choose the
curve to fit and the initial guesses for the fit parameters.

Second Order... Opens a dialog, allowing you to choose the curve to fit and the
initial guesses for the fit parameters.

Third Order... Opens a dialog, allowing you to choose the curve to fit and the
initial guesses for the fit parameters.

Analysis -> Fit Exponential Growth... Performs an exponential growth fit of the se-
lected curve.

Analysis -> Fit Lorentzian Performs a lorentzian fit of the selected curve. It can be
used to obtain a correlation equation of a bell shaped data set.

Analysis -> Fit Gaussian Performs a gaussian fit of the selected curve.lt can be used
to obtain a correlation equation of a bell shaped data set.

Analysis -> Fit Bolzmann (sigmoidal) Performs a fit to a bolzmann function of the
selected curve. It can be used to obtain a correlation equation of a S shaped data
set.

Analysis -> Fit Multi-peak ->Gaussian... Performs a fit to a sum of N gaussian func-
tions of the selected curve.

Analysis -> Fit Multi-peak -> Lorentzian... Performs a fit to a sum of N lorentz func-
tions of the selected curve.

3.9 The Table Menu

This menu is only active when a table is selected.

Set Column As These commands are used to define the kind of data which is stored
in the different columns of a table.

Set Column As -> X Define the selected column as abscissae for the plots. You
can define more than one column as X-values in a tables, they will be ref-
erenced as X1, X2, etc.

Set Column As -> Y In the case of 2D plots, this command defines the selected
column as Y-values for the plots. In the case of 3D plots, Y columns can
be used as the second abscissae.

Set Column As -> Z In the case of 3D plots, Z columns will be used as plotted
values.
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Set Column As -> X error Define the selected column for use as error bars
width for abscissae.

Set Column As -> Y error Define the selected column for use as error bars for
Y-values.

Set Column As -> None The selected column can be used in different ways in
several plots (as X values, Y values, etc).

Column Options... This command is used to define the global parameters of each
column such as numeric format, column name, etc. See the corresponding dialog
box section for more details.

Set Column Values... This command is used to fill the selected column with the values
resulting from a mathematical formula. See the corresponding dialog box section
for more details.

Recalculate When you fill a column (named for example *C1°) with the results of a
formula (by using the Set Column Values... command), the values of the column
are calculated only once when you define the formula. If your formula depends
on values of another column (name for example *C2’), the values of *C1’ are not
updated if you modify the values in ’C2’. This command is used to recalculate
the values of the selected column.

Fill column with This command is used to fill the selected column with special val-
ues:

Fill Column With -> Row Numbers The filling is done with the number of the
corresponding rows.

Fill Column With -> Random Numbers The filling is done with random val-
ues between 0 and 1.

Clear Removes all the values of the selected column

Add Column Adds a new column in the table. Whatever the selected column, the new
one will be inserted at the right of the table after the left column.

Columns Allows to define the number of columns in the table. Be carefull if you
decrease the number of columns in a table, a number of columns will be removed
and the data will be lost.

Rows Allows to define the number of rows in the table. Be carefull if you decrease the
number of rows in a table, a number of rows will be removed and the data will
be lost.

Go to Row... Defines the active line in the selected table.

Convert to Matrix This command is used to convert a table into a matrix. It is mainly
used to import data from files: the first step import data in a table, and the second
one is the conversion of the table in a matrix.
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3.10 The Matrix Menu

This menu is only active when a matrix is selected.

Set Properties... This command opens a dialog window which is used to specify some
view parameters of the matrix (cell width, format of numbers).

Set Dimensions... This command opens a dialog window which is used to specify the
size of a matrix. It can also be used to specify the X and Y ranges which will be
used as axis ranges for a 3D-plot of the matrix data.

Set Values... This command opens a dialog window which is used to fill in a matrix
with the result of a function z=f(i,j) in which i and j stand for the row and column
numbers.

Transpose Transpose the selected matrix.
Invert Inverse the selected matrix.
Determinant Compute the determinant of the selected matrix.

Convert to Spreadsheet Convert the selected matrix in a table.

3.11 The Format Menu

This menu is only active when a plot is selected.

Plot... In the case of a classical 2D plot, opens the format plot dialog with the general
plot options tab selected. It allows to customize the line styles and colors of plot
frame, etc.

In the case of a surface plot, this command opens the surface plot options with
the general plot options tab selected. In this case the aspect ratio of the plot can
also be modified.

Curves... Opens the Custom Curves dialog. It allows to customize the line style and
colors used to draw curves.

If the selected plot is a surface plot, this menu item is not showed.

Scales... Opens the format plot dialog with the scales tab selected. It allows to cus-
tomize the ranges of the differents axes. It must be reminded that any modifica-
tion in the table or in the plotted curves will result in a reset of these scales to the
default values.

In the case of a surface plot, this command opens the surface plot options with
the scales options tab selected.

Axes... Opens the format plot dialog with the axes tab selected. It allows to customize
the settings for the different axes such as the size and color of axes and ticks, the
label of the axes, etc.
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In the case of a surface plot, this command opens the surface plot options with
the axis options tab selected.

Grid... Opens the format plot dialog with the grid tab selected. It allows to add and
customize grid lines on the different axes.

If the selected plot is a surface plot, this menu item is not showed.

Title... Opens a text options dialog, allowing you to modify the title of the plot and its
properties (color, font, alignement).

In the case of a surface plot, this command opens the surface plot options with
the title options tab selected.

3.12 The Window Menu

Additionaly to the items listed bellow, this menu will also display a list with the first
ten windows created in the workspace. These windows can be made active or can be
shown if they are hidden, by selecting their name from the list. If your project contains
more then ten windows, you must use the Project explorer in order to perform these
operations.

Cascade Arranges the visible windows in the project in a cascading style.
Tile Tiles the visible windows in the project.
Next (F5) Makes the next visible window in the workspace stack the active window.

Previous (F6) Makes the previous visible window in the workspace stack the active
window.

Rename Window Opens a dialog allowing to change the title of the active window.
Duplicate Clonates the active window.

Window Geometry... Opens a dialog allowing to change the size and the position of
the active window. The size of the plot will be adapted to the new window size.

Hide Window Hides the active window. A hidden window can be made visible again
via the Project explorer.

Close Window (Ctrl-W) Closes the active window. You will be prompted out a ques-
tion dialog asking you to confirm the operation, if you checked this option in the
Preferences dialog ("Confirmations" tab).
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3.13 Customization of 3D plots

Theses commands are not available through any menu nor by any keyboard shortcut.
They can be accessed through the 3D toolbar.
Frame This command can be accessed by a click on the L.

Draws only the three axis on the active 3D plot.

Box This command can be accessed by a click on the (I

Draws the three axis on the active 3D plot, and a box around it.

No axes This command can be accessed by a click on the 7

Doesn’t draw the three axis nor the box on the active 3D plot.

Front Grid This command can be accessed by a click on the &
Draws a grid on the front panel of the active 3D plot. The position of this grid is
the plan defined by y=ymin-

Back Grid This command can be accessed by a click on the &
Draws a grid on the back panel of the active 3D plot. The position of this grid is
the plan defined by y=ymax-

Left Grid This command can be accessed by a click on the (%
Draws a grid on the left panel of the active 3D plot. The position of this grid is
the plan defined by X=Xp;p-

Right Grid This command can be accessed by a click on the £

Draws a grid on the right panel of the active 3D plot. The position of this grid is
the plan defined by X=Xpax.

&7,

Ceiling Grid This command can be accessed by a click on the &%
Draws a grid on the top panel of the active 3D plot. The position of this grid is
the plan defined by z=zax.

Floor Grid This command can be accessed by a click on the &

Draws a grid on the floor panel of the active 3D plot. The position of this grid is
the plan defined by z=zj.

Enable perspective This command can be accessed by a click on the &

Enables/Disables the 3D perspective mode.

Reset rotation This command can be accessed by a click on the &

Resets the rotation of the 3D plot to the default values.

Fit frame to window This command can be accessed by a click on the &

Finds the best layout of the 3D plot fitting the window size. It readjusts the length
of the axis ticks to a default value.
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Bars Style This command can be accessed by a click on the 4
If the active 3D plot is a 3D histogram, this command is used to modify the style
of the bars.

Dots This command can be accessed by a click on the .
If the active 3D plot is a 3D scatter, this command is used to modify the style of
the data points to dots.

Cones This command can be accessed by a click on the %
If the active 3D plot is a 3D scatter, this command is used to modify the style of
the data points to cones. It is then possible to modify the drawing parameters of
the cones by double clicking on the plotting area.

Cross Hairs This command can be accessed by a click on the
If the active 3D plot is a 3D scatter, this command is used to modify the style of
the data points to cross-hairs. It it then possible to modify the drawing parameters
of the crosses by double clicking on the plotting area.

3D Wire Frame This command can be accessed by a click on the &
If the active 3D plot is a 3D surface, this command is used to modify the style of
the surface to a simple wireframe.

3D Hidden Lines This command can be accessed by a click on the A
If the active 3D plot is a 3D surface, this command is used to modify the style of
the surface to a wireframe. A computation of the hidden line is done.

3D Polygons This command can be accessed by a click on the &
If the active 3D plot is a 3D surface, this command is used to modify the style of
the surface to polygons.

3D Wire Surface This command can be accessed by a click on the &
If the active 3D plot is a 3D surface, this command is used to modify the style of
the surface to polygons with a mesh.

Floor Data Projection This command can be accessed by a click on the =
If the active 3D plot is a 3D surface, this command is used to add a filled area
projection of the surface on the floor of the plot.

Floor Isolines This command can be accessed by a click on the =

If the active 3D plot is a 3D surface, this command is used to add an isoline.

Empty Floor This command can be accessed by a click on the —

If the active 3D plot is a 3D surface, this command is used to remove any pro-
jection from the floor.

Animation This command can be accessed by a click on the 8%

Enables/disables animation.
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Chapter 4

The Toolbars

All toolbars can be moved and docked to a more convenient location (left, right or bot-
tom sides of the application window) or on the desktop (outside the main window) by
drag-and-drop, using their left side handle. The toolbars are automatically enabled/dis-
abled depending on the currently active window: for example if the current window is a
table, the Table toolbar will be enabled and all the other toolbars will be automatically
disabled.

The same approach is used for showing/hidding the toolbars: if there are no more
visible tables in the workspace, the Table toolbar will be automatically hidden and will
be shown again when the users adds a new table into the project. A toolbar can be
manually shown/hidden by the user, at any time, by right-clicking on the main window
menu area and checking/unchecking the corresponding box in the pop-up menu.

4.1 The Edit Toolbar

S s2BD

Figure 4.1: The SciDAVis Edit Toolbar

4.2 The File Toolbar

The File Toolbar allows to access commands mainly from the File menu. Refer to this
section for a more complete description of these commands.

DR s R @2 [m
Figure 4.2: The SciDAVis File Toolbar
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Icon| Command Key Description

Undo the last command, this feature
doesn’t work for plot modifications.
Redo the last command, this feature
doesn’t work for plot modifications.

9 | Undo command Ctrl-Z

@ | Redo command Ctrl-R

Cut Selection

* Ctrl-X | Cut the current selection.
command
Copy Selection .

24 Ctrl-C | Copy the current selection.
command
Paste Selection .

B Ctrl-V | Paste the current selection.
command
Delete Selection .

B Delete the current selection.
command

Table 4.1: Edit toolbar commands.

4.3 The Plot Toolbar.

This toolbar is only active when a plot window is selected. It allows the quick access
to the commands of the Graph menu and of the Data menu which are used for the
modification of the plots and of the data points of the plots.

Bleea aas ¢+ 4

Figure 4.3: The SciDAVis Plot Toolbar

4.4 The Table Toolbar.

This toolbar allows a quick access to the commands of the Plot Menu used to plot the
datas of the table.

Figure 4.4: The SciDAVis Table Toolbar
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Icon| Command Key Description
O Nev.v > New Ctrl-N | Create a new project.
Project command
New ->New Table |t | Create a new table.
command
New g New Create a new matrix.
Matrix command
\ New -> New Note .
] Create a new note window.
command
New -> New Graph Ctrl-G | Create a new empty 2D plot.
command
New > New Creates a new plot based on a function
42 | Function Plot Ctl-F
Y=£(X).
command
New -> New
s | Surface 3D Plot Ctrl- Creates a new 3D plot based on a func-
. Alt-Z | tion Z=f(X,Y).
command
& | Open command Ctrl-O | Opens an existing SciDAVis project file.
& Open Template Opens an existing template SciDAVis
command project file.
| Save Project Ctrl-S | Saves the current project.
command
=2 Save as Template Saves the current project as a template.
command
- Irpp ot A.SCH i Imports an ASCII file into one single ta-
= | Single File...
ble.
command
- Import ASCII -> Imports an ASCII file into multiple ta-
= | Multiple Files...
bles.
command
= | Duplicate . .
= Clonates the active window.
command
& | Print command Ctrl-P | Print the active window.
A Project Explorer Cul-E | Show or hide the project explorer.
command
Results log Show or hide the results window.
command

Table 4.2: File toolbar commands.
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Icon| Command Key Description
L | Add Layer AlLL Adds a new layer to the active plot win-
dow.
t: | Arrange Layers AlA Arranges the different layers of the ac-
tive plot window.
by Add/Remove AlLC Adds Or removes curves to the active
Curves... plot window.
i Add Error Bars... Ctrl-B Adds error bars to a curve of the active
plot window.
. Ctrl- Adds a curve based on a function to the
fu | Add Function... . .
Alt-F | active plot window.
New Legend Ctrl-L AFlds a new legend to the active plot
window.
Comes back to the normal pointer
K Disable tools mode, this is useful when you haye se-
lect other modes of the plot window
such as the data reader.
& | Zoom in Ctrl-+ Switches the active plot layer to the
zoom mode.
& | Zoom out Ctrl-- Switches the active plot layer to the
zoom mode.
% | Data Reader Cul-D | Switches the data display mode.
# | Select Data Range AILS Switches the active plot to the Select
Data Range mode.
. Screen Reader Switches the active plot layer to the
Screen Reader mode.
® | Move Data points Ctrl- Allows to move data points on the ac-
Alt-M | tive plot.
Remove Bad Data Al-B Allows to remove data points on the ac-
Points tive plot.
A | Add Text command | AILT 3?)? a new text element in the active
Draw Line Ctrl- . .
7 command Alt-L Add a new line on the active plot.
Draw Arrow Ctrl- .
}
command Alt-A Add a new arrow on the active plot.
. Add Time Stamp Ctrl- . .
@
& command AlLT Add a time/date label on the active plot.
5] Add Image Alt-1 Insert a new image in the active plot.
command

Table 4.3: Plot toolbar commands
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Icon | Command Key Description

plot -> Line plot with the line style.

" | plot -> Scatter plot with the scatter style.

< Ipili(r)ltefSymbol plot with the line+symbol style.

plot -> Columns plot with the columns style.

plot -> Rows plot with the rows style.

W | plot-> Area plot with the area style.

& | plot->Pie plot with the pie style.
plot -> Statistical

# | Graphs -> plot with the histogram style.
Histogram

v Igilsg);;Vectors plot with the vector style.

@ | Pot>Ploib > plot with the 3D ribbons style.

@ | plot -> Bars plot with the 3D bars style.

% | plot -> Scatter plot with the 3D scatter style.

@ E“lr(;;e_;:rl;t 3D -> plot with the trajectory style.

‘B Iélgltu;nAdd add a new column to the table

£ plot -> Statistics on compute statistical parameters on se-
Columns lected columns

5 plot -> Statistics on compute statistical parameters on se-

Rows

lected row

Table 4.4: Table toolbar commands.
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4.5 The Plot 3D Toolbar.

Surface 3D

Ll

Shan dizs AMMA ®lo 80

Figure 4.5: The SciDAVis Plot 3D Toolbar
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Icon | Command Key Description
| plot -> Frame Draw only the three axes.

Draw the three axes and the 3D box
@ | plot->Box

around the plot.

plot -> No axes

Doesn’t draw the axes nor the box.

plot -> Front Grid

Draw a grid on the front panel.

plot -> Back Grid

Draw a grid on the back panel.

plot -> Left Grid

Draw a grid on the left panel.

plot -> Right Grid

Draw a grid on the right panel.

plot -> Ceiling Grid

Draw a grid on the top panel.

plot -> Floor Grid

Draw a grid on the bottom panel.

plot -> Floor Grid

Draw a grid on the bottom panel.

plot -> Enable

Enables/Disables the 3D perspective

- perspective mode.
5 plot -> Reset Resets the rotation of the 3D plot to the
rotation default values.
Finds the best layout of the 3D plot
" plot -> Fit frame to fitting the window size. It readjusts
window the length of the axis ticks to a default
value.
d | plot-> Bars Style Changes the styles of the bars.
Draw the 3D scatter points with the dot
plot -> Dots
style.
} Draw the 3D scatter points with the
3 | plot -> Cones
cone style.
# | plot -> Cross Hairs Draw thfi 3D scatter points with the
cross-hairs style.
A plot -> 3D Wire Draw a surface with the wireframe
Frame style.
A plot -> 3D Hidden Draw a surface with the mesh style
Lines (with hidden lines).
AL 11:)’1001;/:;3:) Draw a surface with the polygons style.
& plot -> 3D Wire Draw a surface with the mesh+polygons
Surface style.
plot -> Floor Data Draw a projection of the plot on the
- Projection floor.
& | P IOt.-> Floor Draw an isolines projection on the floor.
Isolines
~ gll?)i)f Empty Draw an empty floor.
88 | plot-> Animation Enables/Disables animation.

Table 4.5: 3D Plot toolbar commands.
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Chapter 5

The Dialogs

5.1 Add Error bars

This dialog is activated by selecting the Add Error Bars... command from the Graph
menu.

This command is used to plot X and/or Y error bars around the data points.

It must be taken care that the "add" button add the errors bars, and so do the "OK"
button. Then, you should close the dialog with cancel if you have clicked on the "add"
button.

Add Errar Bars 1o [Tah\m_z :] [ Add ]
Source of errars
& Existing column
Percent of data (%) 5
Standard Deviation of Data
X Errar Bars @ ¥ Ertor Bars

Figure 5.1: The Add Error Bars... dialog.

There are three ways to specify the size of the bar:

A column of the table In this case, the values of the selected column are used to com-
pute the error bars. if V is the value of the data point, and E the value of the
errorbar column, the size of the bars will be V-E to V+E.

A percentage of the values if E is the percentage selected, the size of the bars will be
V(1-E/100) to V(1+E/100). It must be noticed that, in addition to the errorbars
on the plot, this command will create a new column in the active table with can
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be used in the way as with the previous option. This column can be modified like
any other one.

The standard deviation of the values the standard deviation of the values. This has
a meaning only of the data are centered around an average value. Like with the
previous option, a new column will be created in the active table.

L
[
[

[ graphz

(3]
R

3
= 1+
S o] :
)

13 F—i

2 | 3

3 3

4 : : e T T T

] 1 2 3 1 5 6 9

X values

Figure 5.2: A plot with X and Y Error Bars.

5.2 Add Function

This dialog box is used to add a function curve to the active plot. The function can be
built with the common operators: * + /- and " for the power. The intrinsic functions
available are listed in the appendix.

The most common way to define a function is the classical cartesian coordinate
definition y=f(x), this is the defaut option. The two following parameters allow to
select the x range used for the plot, and the last one is used for the number of data
points that are computed in the X-range.
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Add function curve olx

Curve type IFunction :]
sing+Cos(
)=
From x= [u ]
To x= [a ]
Paints [mn I%]
ClearFunction | [ ok |[ close |

Figure 5.3: The Add Function... dialog box: cartesian coordinates.

The functions can also be defined in a parametric definition: if ¢ is the parameter,
the (x,y) data points are computed by x=f(t) and y=g(t).

The first parameter is the name of the parametric variable (here ¢) followed by the
range, the definition of the two functions and the number of data points.

Add function curve olx

Curve type lParametr\c plot :l
Parameter It ]
Fram [U ]
To [1 ]
%= |vs -
y = [siniy vl
Paints [mn H

clearlit |[ ok || close |

Figure 5.4: The Add Function... dialog box: parametric coordinates.

The last way is the polar definition of the function: if ¢ is the parameter, the radius
r and the angle theta are computed by r=f(t) and theta=g(t). Then the (x,y) data points
are computed by x=r*cos(theta) and y=r*sin(theta).

The first parameter is the name of the parametric variable (here ¢) followed by the
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range, the definition of the two functions and the number of data points.The angle is
defined in radians, and the constant value pi can be used: it is possible to use 3*pi to
define the parameter range.

Add function curve olx
Curve type |Po|ar plot :]
Parameter |t
From o
To pi
R= |vacosiy -
Theta = [va'sing ~|
Paints [mn I%]
clearlit |[ ok || close |

Figure 5.5: The Add Function... dialog box: polar coordinates.

5.3 Add Layer

This dialog is opened when you want to add a new layer on the active plot. If you
select Guess, SciDAVis will divide the window in two columns and put the new layer
on the right. If you choose Top-Left Corner, SciDAVis will create a new layer with
the maximum possible size over the existing layer, this layer contains an empty plot.
You can then modify the size and position of each layer by selecting it with the layer
number buttons (142 and selecting the Layer Geometry command from the context
menu.

Guess best origin for the new layer?

= Do you want SciDAVIS to guess the best position for the new layer?
\\) Wwarning: this will rearrange existing layers!

[ Guess HIDp—IEﬂEDmErH Cancel l

Figure 5.6: The Add Layer dialog box.

5.4 Add/Remove curves.

This dialog is activated by selecting the command Add/Remove Curves... from the
Graph Menu.
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The left window shows the columns which are available for plotting in the different
tables of the project, and the right window gives the list of the curves already plotted.
In the case presented below, there are two tables in which the Add/Remove Curves...
dialog box allows to select columns. If you use this dialog box to add a column, the X
column will be the one define as X in the corresponding table.

T A6 gy Graphz =l
1] |2[¥] | 3WEN | 4[vEY]
1 1 3,6 0,2009[ 0,6044 Title
z 7 1,7| 0,7687] 0,065
3 3 5,8] 0.8482 0,139
4 4 1,6 0,5795[ 0,9495 —
5 5 7,1 0,3375] 0,3828 ,_I_.
B B 3,9 0,181f 0,03235
Y 7 6.3 03 Add/Remove curves
i Table2 Mew curves style Line + Symhbal 2| | &£ Contour - Color Fill &
Y Y ¥ || e >
1] 2Vl mvailable data Graph contents
1 1
Tahlel_2 S Tahlel_2 Plot gissociations...
3 3 Tahlez_2 Tahlel_3
3 [3 Matrix1 @ Tahlel_4 Edit Range
4 El frrrmm
5 12 Edit Function 7 g
Show Range

Show curtent folder anly

Figure 5.7: The Add/Remove Curves... dialog box.

In this dialog box, if you select one curve of the plot in the right window, you can
change the columns used for X and Y with the Plot Association button. In any case,
you can’t mix the X values of one table with the Y values of another one. If you wan’t
to do this, you have to copy the columns in the same table.

If the curve selected is a function, you can modify it. Refer to the Add Function...
dialog box for more details on functions editing.

5.5 Add Text

This dialog box is opened when you use the Add Text command command from the
Graph menu. If you choose the On new layer option, the text will be inserted as a new
layer which has the size and the position of the text. You can then modify the size and
position of this layer with the layer Geometry (see the Add Layer for details). Beware
that in this case, all text which is not in the layer will be clipped, therefore, you need to
modify the layer to modify the position of the text. If you choose the On Active layer
option, the text will be inserted in the selected layer, and its position can be modified
directly with the mouse inside this layer.
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Add new layer?

\i) Do you want to add the text an a new layer or on the active layer?

[On Mew Layerl IOn Active Layer] [ Cancel l

Figure 5.8: The Add Text dialog box.

5.6 Arrange Layers

This dialog is activated by selecting the command Arrange Layers from the Graph
Menu or by the key code Alt-A.

It allows to modify the geometrical arrangement of the plots which are already
present in the active window. You can also add new layers or remove existing ones.

Arrange Layers

x

Layers Alignement

Layer Canvas Size

a
number (B [2| | Herzantal
Automatic layout | | vertical

Grid Spacing
; =]
Rows 1[5 Pewsse [seees 5
=]

Right margin | 5 pixels

Width 148 |
: pixels Top margin | 5 pixels
Height 235 pixels Eotiom margin |5 pixels

[ ey | ox

(9]
‘o
5
o
@

Figure 5.9: The Arrange Layers dialog

The Arrange Layers dialog is used to modify the geometrical arrangement of the
plots. You can specify the numbers of rows and columns which will define a table of
plots. As pointed out above, you can also add or remove layers with this dialog, using
the "Number of Layers" box.

With the default setting, SciDAVis computes the size of the layers from the size of
the window. If you check the Layer Canvas Size, you can set the size of the layers and
SciDAVis will modify the size of the window.

The two right zones allow to set the alignement of the layers in the window, and
the margins between the layer borders and the window limits.

If you do some modifications on your plot, the alignment of the different axis may
not be conserved. You can exec again the Arrange Layers to re-arrange your plot.
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5.7 Add Arrow

This dialog allows to modify a line or an arrow which has been created by the command
Draw Arrow from the Graph Menu or with Ctrl-Alt-A. One can also open it with a
double click on an arrow or a line, or by selecting an arrow or a line and selecting
Properties... with the right button of the mouse.

The first tab allows to change the color, the line type and the line width. This last
parameter is set in pixels. It is possible to define a default style for all the new lines by
pressing the Set Default button.

Line options olx

Cptions | Atrow Head | Geometry

v | Arrow at start Arrow at end
setperault | [ apply [ ok |

Figure 5.10: The Arrow options dialog: first tab

The Arrow head tab is used to modify the shape of the head of the arrow. The
length is set in pixels and the angle is in degrees. It is also possible to define a default
style for the arrow heads using the same Set Default button.

Line options ol x
Cptions | Afraw Head | Geometry
C—
Ca—
v Eilled
setDefaut || apply || ok

Figure 5.11: The Arrow options dialog: second tab

The Geometry tab allows to specify the start and end points of the line/arrow. The
coordinates can be set as a function of the scales values displayed on the left axis (Y)
and on the bottom axis (X) or in pixels, by choosing the desired method from the Unit
pull-down list. The pixel coordinates are relative to the top-left corner of the layer
which contains the line.
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Line options olx

Opt\gns] Arrow Head | Geometry

Unit Scale Coordinates =S
Start Paint End Point
®o1.12129 X 4.39832
To B.14815 To |G44444

Set Default Apply ak

Figure 5.12: The Geometry dialog: third tab

5.8 Column Options

This dialog is activated by selecting the command Column Options... from the Table
Menu. At least one column must be selected.

Column options o'x

| =sPrev. |[ReD2

Column Mame: |RZDZ

Enumerate all to the right

Options

Plot Designation: ¥ (ahscissae) H

Display Numetic S

Format: Default S
(]

Apply to all columns to the right

Calumn Width E pply to all

cCamment:

Display Comments in Header

Figure 5.13: The Column Options... dialog.

The checkbox Enumerate all to the right can be used to build the name of all the
columns which are at the right of the selected one. If the name of the selected column

is "xyz", this column and the following ones will be renamed to "xyz1", "xyz2", and so
on.

6
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The buttons "«" and "»" are used to change the selected column. The highlighting
of the column in the table behind the dialog box will change indicating that a new
column was selected. The column to which the formatting commands are applied is
the one whose name appear in the "Column Name" box.

The Plot Designation selector is used to define the columns which are used as X, Y
or Z values or as error bars. In a table you can select several columns as X, in this case
in the column label they will be indicated as [X1], [X2], etc... and their corresponding
Y columns will be indicated as [Y1], [Y2], etc...

5.9 Contour Curves Options

This dialog is activated by clicking on a contour curve (or on the plotting area) when
a 3D plot has been created from a matrix with one of the following commands of the
Plot3d menu: Contour+Color Fill command, Countour Lines command or Gray Scale
Map command.

¥ Plot details x
B %) Graphd tes | Colors / Contour
=] Layerl

P Matrix] v Image
Gray Scale
@ Default Color Map

Custom Color Map

v Contour Lines

5 [mme
Levels ﬂ
Use Color Map
@ Use Default Pen
v | Color Bar Scale
s Right z
C—
it type Conour ¢/ Image| #| [z [ worsheet |[ oK ][ gancel | appy |

Figure 5.14: The Contour Options dialog.

The first group of settings Image is checked if you want to have a color or gray
level filling of the contour plot. The default gray and color maps are the following:

-0.4 -0.2 0 0.2 0.4 0.6 0.8 1




You can customize this colormap by checking the Custom Colors box. A table
with a set of numbers (the Z levels) and the corresponding colors is presented. You
can then add or delete new levels for the definition of the colormap, and modify the
corresponding Z levels. You are not allowed to modify the first and last levels, which
are set to the minimum and maximum Z values. Beware that this is only the definition
of the colormap, it won’t change the number of contour lines of your plot. An example
of classical custom colormap is given here:

@ m

AXES Caolors £ Contour

Image

Level Colar
. Gray Scale — J

1
. .,

. Default Color Map
‘@ Custom Color Map

Insert Delete 0

[v] Scale Colors \||||\|\||\|\||||\|\|

V¥ Axis Title

b Axlﬂ Title

If you want to obtain discrete colors for each level,you must uncheck the Scale
Colors checkbox. In this case you must define enough levels in your colormap.

Plot details x @I Graph3 m=E
AKes Colors ¢ Contour
Image
Lavel Colar '
B 0.0196 -
. Gray Scale s
s [ g
 Default Color Map >
1 A
‘@ Custom Colar Map
Insert Delete
D §Ca|9 Colors T ‘ T T | LI T | T LI ‘ T T | 1 o
xnm Title

The second group of settings is used to customize the contour lines. You can select
the number of lines and their color. If you check Use Default Pen, the color of the line
will follow the settings defined in the group at the left of the checkbox. If you check
Use Color Map, the lines will be colored as a function of the Z levels following the
colormap defined in the image setting group.

The last group of settings must be checked if you want to have a bar scale on your
plot. You can then define its position and width.
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5.10 Custom Curves

This dialog is activated by selecting the command Plot... from the Format Menu. It
is also activated by a double click on the plot. If there are more than one layer in the
window, SciDAVis will select the layer which contain the plot under the mouse pointer.

Plot details x

B Graph2 WW
=] Layer]
Fill area under curve
- [ Tablel: R2D2(X),2(¥),3(<EM) Connect
L[] Tahlel: R2D2(X),2(Y)AVEM) Fill colar m black 2
Pattern S
Plot type Line + Symbol :l l Warksheet H oK H Cancel H Apply Hﬂ\ot Associations...

Figure 5.15: The Custom Curves Dialog: Line formatting.

The right part of the dialog box contains several tabs which depend on the kind of
plot that you are using, they are described in the following subsections. The left part
of the dialog window shows the curves which are plotted in the active layer. All the
modifications will be done on the selected curve. You can change the columns which
are used by clicking on the Plot Associations... button. This will open a dialog which
can be used to select the columns of the table which are used as X and Y values.

Plot Associations alx
Spreadshest: Tablel
Column H b
RZDZ v
2 v

3

Tablel: RZDZ(X)jZ(Y).‘l(VE")

Update curves || oK | [ cancel

Figure 5.16: The Custom Curves Dialog: Plot Associations.

The button Worksheet can be used to access to the table which contains the columns
selected.
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5.10.1 Custom curves for lines and scatter plots

This dialog box is activated for plots drawn with symbols, line+symbols, lines, vertical
drop lines, steps and splines.

The first tab of the right part of the dialog window allows to modify the style of the
line (color, line style, thickness). The connect button allows to change the style which
is used to draw the selected curve (steps, droplines, etc). See the Plot menu to see the
different types of plot available.

x Plot details x

%) Graph? WW
=] Layerl
Fill area under curve
- 2] Tablal: R2D2{X),Z(¥),3(EmM) Connect
.- [ Table': R2DZ(X),2(+) A(YEM) Fill colar m black -
Pattern =
wan
Plot type Line + Symbal | 4| [ worksheet | ok || cancel | apply | [Plot Associations..

Figure 5.17: The Custom Curves Dialog: Line formatting.

A second tab can be activated to select the symbol, and to modify the size, the color
and the filling color of the symbols.

Plot details x

E-?rigsgn #xes | Line | Symbol
- [] Tablel: REDZ(4),2(),3(EH) Style (O Filipse <]
* [ TableT: RZD2() Z(¥),AVEN)
Size [3 =
| Fill Colar [ mmbtack 5
Edge Color [- hlack :]
Edge Width [ B
Plot type Line + Sympol | 3| | workeheet || ok || cancel |[  apply  |[Plot associations..

Figure 5.18: The Custom Curves Dialog: Symbol formatting.

5.10.2 Custom curves for pie plots

These commands are available for pie plots. The first tab allows the customization of
the pie segments. The left fields are used to modify the border which is drawn round
each segment: color, type and width of line. The default is no border (line width = 0).
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The right fields are used to define the filling of the plots. The color button defines
the one used for the first segment, then the others segments will have colors which
follow the order defined in the list. The default value for this field is black, so segment
2, 3, etc will be red, green, etc.

The pattern will be used for all segments of the pie, the default value is solid filling.
The last field defines the size of the pie in pixels.

Plot details x
B ) Graphd Pie
=] Layer!

I Tahlel: 2 Barder Fill

Color | mmblack S First color | mm black

A

Plot type Fie 2] [ﬂnrksheet][ ok || cancel || appy |

Figure 5.19: The Custom Curves Dialog for pies: pie segment formatting.

5.10.3 Custom curves for box plots

X
5 Plot details x
£} 1) Graphd Axes | Pattern | Bowhiskers 1 Percentile I
=8 Layer
& Tablel. 2 Fill area under curve
Connect Lines s
Fill color mm hlack S
Pattern =
N
Color mmblack s
Plot type Bax $| [z || worksheet | ok || cancel || appy |[Piot associations..

Figure 5.20: The Custom Curves Dialog for box: pattern formatting.
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b Plot details x

B Graphd Axes ] Pattern | BoxWhiskers | Percertile }
=] Layer

Box ‘Whiskers
Type Rectangle S Range 95-5 S
Range Ferc 25, 75 S

Plot type Box :l [ Worksheet H oK H Cancel l[ Apply ][E\Dt Associations

Figure 5.21: The Custom Curves Dialog for box: whiskers formatting.

5 1 Graphd Pxes | Patiemn | BosWhiskers | Percentile |
=] Layer!
Type Symhol
- A
39% Ko Symbal s Fill Color | mm black s
hdean Edge Color . black S
Plot type Box 3 [ﬂorksheet][ ok |[ cancel || apply | [Blot Associations..

Figure 5.22: The Custom Curves Dialog for box: percentile formatting.

5.10.4 Custom curves for pie histogram

X
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Plot details x

B Graphd
=] Layer
F.

&xes | Pattern ‘ Spacing | Histogram Data |
v | Fill area under curve
Connect Lines S
Fill colar e =
Pattern [ BDiagonal S
wan
Color i red S
Histogram 3| [ [ womenset [ ok ][ cancal || spply | [Elot Assasiations..

Plot type

Figure 5.23: The Custom Curves Dialog for histogram: pattern formatting.

Plot details x

Spacing ‘ Histogram Data |

B Graphd
=] Layer

#xes | Pattemn

Gap Between Bars (in %) [D '%]
Cffset (in %) [n H
Histogram 3| | workeheet || ok || cancel |[ apply  |[Piot Associations..

Plot type

Figure 5.24: The Custom Curves Dialog for histogram: spacing formatting.

Plot details x
Histogram Data ‘

B Graphd
=] Layer

#res | Pattern | Spacing

| Automatic Binhing

Bin Size |0.7
Begin |1

End i

Show stafistics

oK

3] l Waorksheet H

Histogram

|| cancal || appy

] [E\Dt Associations...

Plot type

Figure 5.25: The Custom Curves Dialog for histogram: data formatting.
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5.11 Define surface plot

This dialog is used when you enter the New -> New Surface 3D Plot command. It
allows to create a new function of two variables. The only available coordinate system
is the cartesian one: z=f(Xx,y).

Tiy)= [(sin(x)**2+cos(y)“Z)f(5+><”2+y”2) ,]
X - axis ¥ - axis Z - axis
From |-5 From -5 From |0
To 3 To 3 To 1
ok || clearsist || close

Figure 5.26: The New -> New Surface 3D Plot dialog box.

You can then enter the X, Y and Z scales.

5.12 Export ASCII

This dialog is activated by selecting the command Export ASCII from the File Menu.
It is only active when a table is selected.

This command is used to export all or a part of the data of a project in an ASCII
file.

In this example of export of a selection in a table to an ASCII file, TAB is used as a
separator between the columns.

= Tahlel =N - Export ASCIl
R2DZ 2[Y] | 3REN | 4[vEY]
1 — 16044 Tahle Tablel S All
3 0,139
1 0,34395 v Include Column Mames
5 09828 v| Expaort Selection
[ 0,03235
7 DA7ET (o [ cancer |[ bep |

Figure 5.27: Export of a selection in a table to an ASCII file.

If the names of the columns have not been set, they will be set to C1,C2,... in the
exported file. The formatting of the numbers is kept in the ASCII file, so you have to
be carefull to obtain a good enough precision in the ASCII file.
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5.13 Fast Fourier Transform

The FFT... dialog box can be used either on a table or on a plot. It is used to compute
a direct or inverse FFT. See the FFT section in the Analysis chapter for an example.

¥ FFT Options olx
@ Eorward Inverse
Curve Tahle1_2 =

Sampling Interval |1

v| hormalize Amplitude

v| Shift Results

Figure 5.28: The FFT... dialog box for a curve.

SciDAVis will create a new plot window with the FFT amplitude curve, and a new
table which contains the real part, the imaginary part, the amplitude, and the angle of
the FFT.

If the Normalize Amplitude check box is on, the amplitude curve is normalized to
1. If the Shift Results check box is on, the frequencies are shifted in order to obtain a
centered x-scale.

FFT Options

ox
@ Eorward Inverse

Sampling Tahlel_RZD2 =

Real Tahlel_2 2

=

Imaginary

:

Sampling Interval |1

| Mormalize Amplitude

v| Shift Results

Figure 5.29: The FFT... dialog box for a table.

In the case of a table, you must select the sampling column (X-values) and two
columns for Y-values. If they are complex numbers, the first column is the real part of
Y-values and the second is the imaginary part. If Y-values are simple reals, you must
select the same column for real and imaginary part.

By default, the Sampling Interval corresponds to the interval between X-values.
Giving a smaller value makes no sense, but you can increase this value in order to
sample less values
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5.14 Integrate dialog

This dialog box is opened if you select the Integrate... command from the Analysis
menu The first field is the curve that will be integrated. The second one is the order of
the integration: the order 1 corresponds to the trapezoid rule, i.e. the curve is aproxi-
mated by a straight line between 2 successive points. If you choose the order 2, three
successive points are used and a second order polynome is used to approximate the
curve. etc. If you have a large amount of points in your curve, the order 1 is enough.

Integration Options olx
Integrate
Integration of Tahle1_2 S

. Help

Order (1 - 5, 1 = Trapezoid Rule) [1 @
S Close

Mumber of iterations (Max=40)

Talerance 0.01

Lowet limit 1

Upper limit 7

Figure 5.30: The Integrate... dialog box.

The result of the integration will be given in the The Project Explorer.

5.15 Non linear curve fit

This dialog is activated by selecting the command Non Linear Curve Fit... from the
Analysis Menu. This command is active if a plot or a table window is selected. In
the latter case, this command first creates a new plot window using the list of selected
columns in the table.

This dialog is used to fit discrete data points with a mathematical function. The
fitting is done by minimizing the least square difference between the data points and
the Y values of the function.

Note: If the data points are modified, the fit is not re-calculated. Then, you need to
remove the old fitted curve and to redo the fit with the same function and the new
points.

The top of the dialog box is used to choose a function among the one which are
already define. Four types of functions are availables: the user defined functions which
have been saved, the classical functions proposed by SciDAVis in the analysis menu,
the simple elementary built-in functions, and external functions via pluggins.

To choose one of these functions, you just have to select it and to click on the
checkbox under the selector.

If you want to define your own function, you can use the bottom half of the dialog
box. You can write you own mathematical expression or add expressions obtained with
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the function selector. Then you need to define the parameters which have to be fitted
in a comma separated list.

This first step is used to define the function which will be used for the fitting
L === < 1 5 |

Category Function Expression
User defined Boltzmann [«] | yD+a expi-)
Expitowth
Basic ExpDecayl
Plugins ExpDecay?
ExpDecay3
GaussAmp
Gauss
Lorentz =
Folynomial |-
v| Fit using built-in function
Mame ExpDecayl Save
Parameters | &, 1, y0 Remove

0+ APty Add expression

Add name

Reset

Figure 5.31: The first step of the Non Linear Curve Fit... dialog box.

The second step is to define the parameters for the fit. You have to give initial guess
for the fitting parameters.
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This second step is used to define the parameters of the fitting

Curve [Tab\e‘\_z ¢]
Function ExpDecayl (x, A, t, y0)

Y0+ Ao et

Parameter Yalue

A 1,000000000000000
AN GPUB0058 | 1,000000000000000

o 1,000000000000000
Algarithm [Scaled Levenherg-Marguardt ¢]
Calor [- red ;]

_ q =]
Tao x= 7 Tolerance |1e-4
Weighting Method Mo weighting 4| Tahblel +  RZDZ S
<< Editfunction | [Delete FitCurves || Fit || close || Custom Qutput >

Figure 5.32: The second step of the Non Linear Curve Fit... dialog box.

In this second tab you can also choose a weighting method for your fit (the default
is No weighting). The available weighting methods are:

1. Instrumental: the values of the associated error bars are used as weighting coe-
ficients. You must add Y-error bars to the analysed curve before performing the
fit.

2. Statistical: the weighting coeficients are calculated as the square-roots of each
data point in the fitted curve.

3. Arbitrary Dataset: you have the possibility to set the weighting coeficients using
an arbitrary data set. The column used for the weighting must have a number of
rows equal to the number of points in the fitted curve.

After the fit, the log window is opened to show the results of the fitting process.

Depending on the settings in the Custom Output tab, a function curve (option Uni-
form X Function) or a new table (if you choose the option Same X as Fitting Data) will
be created for each fit. The new table includes all the X and Y values used to compute
and to plot the fitted function and is hidden by default, but it can be found and viewed
with the project explorer.

5.16 General Plot Options

The first tab is used to set the general scales used for the two or three axis.
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General Plot Options ox

Scale | Grid | Awis | General |

01 !u
‘1 Bottom From |0
FD 1 22- StEp ‘
012
To g

om0

i i Left

b cwaprres [s 3
?‘? Tap Type llmear :]

0j3 Inverted

om0

e

Apply l[ QK H Cancel

Figure 5.33: General plot options dialog: the scale tab.

In this tab, you can also set the number of ticks used for each axis. This can be
done in two ways: you can set the number of labels which are used for the whole scale.
Whatever the number you enter, SciDAVis will use a value which leads to a pretty plot:
for example, if you enter 7 ticks for a 0..100 scale, SciDAVis will use 10 major ticks
from 10 to 10. If you want to fix non classical values, you can select the step method.

The grid tab is used to draw grid lines on the plot. The frequency of the lines are
related to the number of label and major ticks set with the Scale tab.
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General Plot Options

Scale | Grid | ez | General |
Ma|or Grids Minor Grids

Line Calar = blue 2| mgray s
g Line Type _ S S
1 Wertical Thickness 1 H [1 2
0 1 2 Axes Bottom Lett *

Additional lines H=0 Y=0

appy |[ ok [ cancel

Figure 5.34: General plot options dialog: the grid tab.

The third tab is used to modify the setting of the different axis. You must select the
axis that must be customized in the right window. The label of the axis can be modified
in the title window, see the text options dialog section for more details.

General Plot Options

Scale } Grid | s ‘ General
Bottom
Left

v| Show
Top

BEEB

|

Title

A Axis Title

Cem s |<[alr]s[~]B]#[u]

+| Show Lahels

Type Mumeric -
Font Ais Font
G
o R
= Formula
ey [ ok || cancel

Figure 5.35: General plot options dialog: the axis tab.

The General settings tab is used to customize the global aspect of the plot. The
canvas is the area defined by the axis, you can draw a box around this canvas and
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define a background color for this canvas. The background area is the global drawing
area, you can also define a color border and a background color for this area. The
margin parameter controls the distance between the drawing area limit and the canvas.
If you want to modify the margin between the window limits and the drawing area, you
must modify the layer parameters (manualy with the mouse or with the arrange layers
dialog.

General Plot Options o'x
Scale | Grid | Ams | General |
Canvas frame Axes
Caolor - & v Draw backbones
i []
Apply l l OK ] [ Cancel

Figure 5.36: General plot options dialog: General settings.

The parameters in the Axes group allow to modify the linestyle of the axes and of
the ticks.

5.17 Plot Wizard

This dialog is activated by selecting the command Plot Wizard from the View Menu or
with the Ctrl-Alt-W key. This command is always active.

This dialog is used to build a new plot by selecting the columns in the tables avail-
able in the current project. At first, you have to select the table you want to use, and
then click on New curve to create the curve. After that, you have to select at least one
column for X and one for Y. You can also select one more column for X-errors or for
Y-errors. The plot created will have the default style you defined using the Preferences
dialog through the 2D Plots -> Curves’ tab.
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In this example, one curve is selected from the first table, and the other from the

¥ Select Columns to Plot O/x
Warksheet Tablel S

RzDZ
Z
3

=

second table (with X error bars)

Figure 5.37: The plot wizard dialog box.

5.18 Project Explorer

The project explorer shows a list of all the windows, tables, matrices and folders which
are included in the current project. It can be used to create new folders and windows, to
find existing ones, to make hidden elements visible, to perform basic operations like:
renaming, deleting, hiding, resizing, printing, etc... You can also use it in order to
display the list of dependencies and properties of an element in the project.

X i--QH-f\\ter-SXGMP|E Name Type |View Size Created 1
fﬁ]:af;]d pass 5§ band pass Folder 0.1kB (128 bytes) 26.10.2006 22:18:41
igh pass i j i 07
I ey Sy TSR
Minimize Window e e
(G low pass mERI3ET. window 128 bytes) 26.10.2006 00:28:06
[Fsignal 06.08.20068 23:57:55
B mtablefitsignal _ Hide Window 07.08.2006 00:07:56
< fmiablesignal W Delgfe Window 64 06.08.2006 23:54:59
w Rename Window F2
.g B Resize Window...
= & Print Window
Properties...
Depends on 4 tablefftsignal |
«l [l | [«

Figure 5.38: The project explorer panel.
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5.19 Preferences Dialog

The preference dialog is used to customize the application. It has six different tabs. If
you confirm your changes to the default behaviour of the application, the changes are
saved and stored imediatelly.

The first icon can be selected to change the General options of the application. In
the first tab: Application, the style is the general decoration used for the windows. It de-
fines the aspect of the buttons and dialog boxes, as an example all screenshots presented
in this manual have been done with the Keramik style available in KDE. The available
styles are part of the Qt library. The font is the general font used for the GUI (menus,
dialogs, etc), it doesn’t apply to the plots. You can select the language of the applica-
tion in the corresponding combo-box. All the available translations can be downloaded
from the following address: http://soft.proindependent.com/translations.html and must
be placed in a folder called translations, situated in the same location as the SciDAVis
executable, in order to be loaded by the application.

Preferences alx

General

Application | Confirmations | Colors | Humeric Fomat

B -
General

Tahles

Language English

A | |0

Style Cleanionks

0 20 Plots

k| 3D Plots Default scripting language Pythan

“w

v| Save every

[
[
Main Font | Choose font
[
[15 minutes

[4¥]

Fitting

~ @ & H

Check for new versions at startup

Apply ][ oK l[ Cancel

Figure 5.39: The preferences dialog: general parameters for the application.

The second tab of the General option set is used to disable the prompting on delet-
ing of objects.

86


http://soft.proindependent.com/translations.html

Preferences

General

Application | Confirmations | Calors I Mumeric Format

Tables Prampt on closing

v| Falders
" 2D Plats v| Tables

v| Matrices
@A 30 Plots +| 2D Flots

v| GD Plots
Fitting

=

| hotes

[ Apply l[ oK ][ cancel ]

In this tab, you can change the default color for the workspace of the application.

You can also choose the background color and the text color for panels. The panels are
the Log Window and the Project explorer.

Preferences

General

Appllcatlon} Confirmations |~ Colors | Numeric Format

Workspace E]
Panels E]
Panels text - E]

Fitting

[ Apply H QK H cancel ]

The second set of option allows to customize the defaut aspect of tables: back-
ground and text colors, and fonts for tables and labels.
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Preferences alx

Tables

r & | General
ll L

Display Comments in Header

Default Colurmn Separator TAB vl

Colars

Al | 20 Fiots

Background E]
@)oo | T I -
—o

Fants

Fitting

Text Fant ] Labels Font ]

Apply ][ oK l[ Cancel

Figure 5.40: The preferences dialog: table options.

The second set of options is used to customize the default aspect of 2D plots. The
first tab is used to modify general options.

Preferences alx

— 2D Plots
l J]Genera\
L Options | Curves | Ticks | Fonts | Print

v Autogcaling v| Scale Fonts

v| Show Title Show all axes

v'| Antialiasing v| Axes backbones

Canvas Frame

3D Plots

s linewidth l 2

Fitting Kargin [D }%]

Do not resize layers when window size changes

Apply ][ oK l[ Cancel

Figure 5.41: The preferences dialog: 2D plot options.

The second tab named Curves defines the default style used when you create a new
plot.
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Preferences 0x

— 2D Plots

T :1 General

! Options | Curves | Ticks | Fonts | Print
Default curve style [ ~ Line + Symbaol :]
Line witth [1 =
Symbol size |3 H

3D Plots

Fitting

[ appy [ ok [ cancel |

The third tab named Ticks defines the default style for the ticks of the axes used
when you create a new plot.

Preferences 0x
2D Plots

I[ :1 General
H
! Options | Curves | Ticks | Fonts | Print

II
KICRKID

3D Plots
Fitting

[ Apply l[ oK ][ cancel ]

The fourth tab named Fonts defines the default style for the fonts used for the axes,
used when you create a new plot.
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Preferences [a}

2D Plots

Options | Curves | Ticks = Fonis | Pririt

iil General
e

@ Tables ( — ]
ml 20 Plaots [ Legend ]

[ Axes Labels ]
4| 50 Piots [ Axes Mutbers ]

] [#]

i??? Fitting

appy |[ ok [ cancel
Preferences alx

— 3D Plots
IEI General
LLa

Resolution 1 (all data shown) =
] e B

v| Show Legend Show Brojection
20 Plots +| Smooth Line Orthoganal

| Autoscaling

Colars

| pammax || Lahels || Meshime || grid |

| patamin || mumbers || axes || Backgrouny |

Fants

[ Title || mwesianels | Numbers |

[ Apply ][ OK l[ Cancel ]

Figure 5.42: The preferences dialog: 3D plot options.
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Preferences alx

p Fitting
u | General

=3l

Generated Fit Curve

Tahles i i = i
E & Uniform ¥ Function  Paints ﬂ /| 2 puints for linear fits
Same X as Fifling Data.

2D Plots
v|Display Peak Curves far Multi-peak Fits

30 Plots Peaks Color [Egreen ¢]
Parameters Output

Fiting

Significant Digits [ 15 I%]

| Write Parameters to Result Log
Faste Parameters to Plat

Scale Errors with sgr(Chi~2/doF)

Apply ][ oK l[ Cancel

Figure 5.43: The preferences dialog: fitting options.

5.20 Printer-setup

This dialog box is opened by the Print command from the File menu. It is used to print
the selected window (plot or table) and its aspect depends on your operating system.
The following screenshot shows this dialog on a Linux system using the KDE window
manager.

Print dialog

Printer

brother :] [ Properties

Printer info: Brother - Brother MFC-3050

Print to file
Print range Copies
@ Print all Number of copies:

Pages fram to Collate

Selection PFrint last page first
Paper format Other
Orientatian: | Partrait = Print in color if availahle
Size Ad = Double side printing

Figure 5.44: The Print dialog.
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5.21 Set Column Values

This dialog is activated by the Set Column Values... command of the Table menu. It
allows to fill a column with the result of a function.

The available mathematical functions (assuming you are using the default script-
ing language, muParser) are listed in the appendix. The special function col(x) can
be used to access to the values of the column x, where x can be the column’s num-
ber (as in col(2)) or its name in doublequotes (as in col("time")). You can also get
values from other tables using the function fablecol(t,c), where t is the table’s name
in doublequotes and c is the column’s number or name in doublequotes (example:
tablecol("Tablel", "time")).

The variables i and j can be used to access the current row and column numbers.
Similarly, sr and er represent the selected start and end row, respectively.

Using Python as scripting language gives you even more possibilities, since you can
not only use arbitrary Python code in the function body, but also access other objects
within your project. For details, see here.

Set column values olx
ac0s() [ s=prev [z NIREER
Return the
are cosing || Forrow (i [1 2] to 4088 iz
(measurad
in radians) [3503 ¢] [ Add function l
of X

[eairy $| mdd cowmn |

col{"z"=
2.2"sinfcol13".75)+1.2"cos(col(1)" 3+1.32)

Figure 5.45: The Set Column Values... dialog.

If you make some changes in the table, the values are not computed again. You
have to explicitly tell SciDAVis to recalculate individual cells or whole columns or
rows by selecting "Recalculate” from their context menu or pressing Control+Return.

5.22 Set Dimensions...

This command is in the Matrix menu. It allows to specify the number of rows and
columns of a matrix

In this window, you can also define X-values and Y-values. These X and Y ranges
will only be used by the 3D-plot, they are not known if you choose to define the content
of the matrix with the Set Values Dialog.
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Matrix Dimensions

Dimensians
Riows ||1m H Columns |1m '%]

Coordinates

H (Columns) Y (Rows)
First | -5 -5

Last |5 3

Figure 5.46: The Set Dimensions... dialog for matrix.

5.23 Set options for Importation of ASCII files.

This dialog is activated by selecting the command Set Import Options... from the File

Menu.
This dialog is used to set the options which are used for the importation of ASCII

data files by the commands Import ASCII -> Single File... and Import ASCII -> Mul-
tiple Files....

2 Import ASCII File(s) ox
Look in: [fhumerknut/sc\dawsfcurrent_slable :l « 5 4 £ =
Computer rdparty ||| CHANGES README scidavis.pro
P party P
knut uging D Doxyfile D scidavis-lago.png
scidavis D gpltst D scidavis-lago.svg
tmp [ mNSTALLAtml [~ scidavis.ces
File name pi=maps.h Cipen

Files of type: [AII filas () ¢] X cancel

Impart each file as: | Use first row to name columns
Separator: Remove white spaces from line ends
Ignare first E Simplify white spaces

Decimal Separators +| Use custom decimal separator

Remember the ahove options

Figure 5.47: The Set Import Options... dialog box.

The first parameter is the separator which is used between the columns. The second
allows to skip the n first lines of the file.

* If you choose to use the first line as column names, you must use the same
separator between the column names and between the data columns.
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* There is no grouping of separators, so if you use "SPACE", you must put only
one separator between each column.

5.24 Set Properties...

This command is in the Matrix menu. It allows to specify some global properties of
the selected matrix such as the cell width (in pixels) and the format for numbers.

Matrix Properties

[+]

Data Format Decimal: 1000 S
(]

apply | ok || cancel |

Figure 5.48: The Set Properties... dialog for matrix.

5.25 Set Values...

This command is in the Matrix menu. It allows to fill in a matrix with the results of a
function z=f(i,j) in which i and j are the row and column numbers.

Even if you have defined X-values and Y-values with the Set Dimensions... com-
mand command, you must use i and j as parameters for the function. In the example
below, X and Y ranges have been defined as 101 values (i and j from 1 to 101) be-
tween -5 and +5. Therefore, the function uses as entries the parameters x=(j-1)/100-5
and y=(i-1)/100-5.

The functions can be written on several lines, and the intrinsic functions which are
available are listed in the appendix .

Set Matrix Values O/x

AC05(3)
o 1 e (o3

Return

b || Fomo [ B =

cosine
(measure acas & | [ unction] | add cen |

iin
[singe* "2 +cos(y) " E(T ey + absiry)10
cali =

Figure 5.49: The Set Values... dialog for matrix.
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5.26 Surface plot options

This dialog box is used to customize a 3D function plot which has been created by the
New -> New Surface 3D Plot command from the File menu. It is activated by a double
click on the 3D plot.

The first tab is used to modify the X, Y and Z ranges. It allows also to specify the
number of labels on the axis and the number of secondary ticks.

Surface Plot Options (=73
Scale ‘ Axis ] Title 1 Colors ] General 1
P Fram -5 Major Ticks
Z
T s Minor Ticks
Type | linear S
matix || appy  |[ ok ][ cancel

Figure 5.50: The surface plot options dialog box.

The second tab defines the main parameters of the three axis: the axis label and its
font, and the length of the ticks. This length is defined in the same units as the range
of the axis. If something is changed in the scales of the graph, the length of the ticks
is re-calculated by SciDAVis. The font button allows to modify only the font used for
the label, if you want to customize the font of the numbers used for the axis, you must
used the fifth tab.

Surface Plot Options olx
Scale | Avdis | Tile | Colors | General |
v Title ¥ axis
z
fds Fant [ choose font | [ a I [ r
Major Ticks Length |1
tinor Ticks Length | 0.6
[ Matrix l[ Apply H oK H Cancel l

The third tab is used to define or modify the title of the plot. You can not add
subscripts/superscripts, bold characters, etc in your title as you can do it for 2D plots.
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Surface Plot Options olx

cale ] Lis | Title | Colors ] General ]

[

[ e || ¢ J[ goer |[ Eomt |

[ Matrix l[ Apply H oK H Cancel l

The fourth tab allows to modify the colors used in the different elements of the plot.

Surface Plot Options olx
Soale | fxis | Tite | Colors | General |
Opamty
Data General Coordinate System
Cwn | e || e || o
e [ amy | [ oo |

The first set of two colors (data min and data max) defines the color scheme which
is used to show the Z-values. They are the colors used for the minimum value of Z
(Znin) and the maximum value of Z (Zp,x). We can define the colors by their Red,
Green and Blue parameters: [R,G,B]. Then, a value Z will be represented by a color
defined as a linear interpolation:

(BB,

) \Z-Z,.)
- | me'.\ - wan | -
|G o =G i)

_ e =Cinl 7
"2 = Z )

B=B. + | Bm-.‘ 7an|
S = i)

The default colors for Z i, and Zy,x are respectively blue ( [R,G,B] = [0,0,255] )
and red ( [R,G,B] =[255,0,0] ). This lead to the following color scheme:

Another classical color scheme can be built with Z;, = [160,32,32] and Zy.x =
[255,255,0] (yellow). It leads to:

Another way to define colors is to read a colormap from a file. The format of the file
is simple: each line defines a color by red, green and blue values as integers between 0

| Z =2 0
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and 255. The numbers should be separated by spaces. You can find several examples
of colormaps on the QwtPlot3D web site.

The last tab is used to define some global parameters and the aspect ratio of the
plot. The default behaviour is to use the perspective to compute the 3D plot. If you
choose to check the Orthogonal check box, the plot will use vertical Z axis whatever
the view angle of the plot.

Surface Plot Options o'x
Scale | fis | Tfle | Colars  General |

v | Show Legend Orthogonal Zoom (%) 316 E
B0 T P B xzeme [0 [
Resalution 1 il datay 2] ||y zoom () =
=]
Numbers Font Choose Font Z Zoom (%) 344 E

Distance labels - ais [0 2]
[ e | appy [ ok [ cancel

Figure 5.51: The surface plot options dialog box with tab 5: aspect ratio.

5.27 Text options

This dialog can be opened by several commands such as Title... command or when you
double click on a text object in your plot. It allows to add/customize the text objects.

Text options olx

Figure 5.52: The text options dialog.

The Color, Font and Alignment commands allow the modification of the general
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http://sourceforge.net/project/showfiles.php?group_id=78209

settings of the text label.
The text item can be modified in the text window. Several improvements can be
added to the text:

* <sub>text</sub> will draw the text as subscripts. You can insert this sequence
by clicking on the *

o <sup>text</sup> will draw the text as superscripts. You can insert this sequence
by clicking on the *

* Byclicking onthe [ °! ,you can open a new dialog which allows to select greek

characters:

x [=[x]
a B vy & =€
 n 6 | K
A p v & o
n p ¢ o T
u ® X v w
o O O 0O

[ Close l

* By clicking on the |7 , you can open a new dialog which allows to select
various mathematical symbols:

x (=]
A B I A E
Z H © 1 K
A M N = O
n p T Y
o X W Q
[ Close l

* <b>text</b> will draw the text with bold characters. You can insert this sequence
by clicking on the '®

* <i>text</i> will draw the text with italic characters. You can insert this sequence
by clicking on the "

e <u>text</u> will draw the text with underlined characters. You can insert this
sequence by clicking on the |
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Chapter 6

Analysis of data and curves

6.1 Fast Fourier Transform

This function can be accessed by the command FFT.... It can be found in the Analysis
Menu when a table or a plot is selected. The Fourier transform decomposes a signal in
its elementary components by assuming that the signal x(t) can be describe as a sum:

xlt =Z a,cos|w t+y, |

EQUATION 6.1.1: Fourier equation

in which . are the frequencies, a, are the amplitudes of each frequency and *-
are the phase corresponding frequency. SciDAVis will compute these parameters and
build a new plot of the amplitude as a function of the frequency.
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FFT performed on a curve to extract the characteristic frequencies. The signal is on
the bottom plot, while the amplitude-frequency plot is on the top layer. In this
example, the amplitude curve has been normalized, and the frequencies have been
shifted to obtain a centered x-scale.

EZ graphs B =] ]
1L]2
1
%D.S
208
Zoa
<02
i B e e e L A e e B s S B
15 1 05 0 05 1 15
Frequency (Hz)
3
2
1
>0
-1
-2
3 L s L L |
0 20 40 60 80 100
X

Figure 6.1: An example of a inverse FFT.

Some parameters of the FFT can be modified in the FFT dialog.

6.2 Correlation

This function can be accessed by the command Correlate. It can be found in the Anal-
ysis Menu when a table is selected. The correlation function, also known as the covari-
ance function is used to test the similarity of two signals x(z) and y(z). It is computed
by:

Rir|=lxtl=x|plt+7]=¥|

EQUATION 6.2.1: Covariance function of two signals x(t) and y(t)

in which and are the mean values of the signals x(7) and y(z) respectively.
If the number of points is N, the function will be computed between -N/2 and N/2.
The abscissae are therefore point numbers and nots values.
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The first plot shows the two signals, the second one is the correlation function
between the two signal which shows that there are correlations, and the third one is
the Fourier transform which is done to extract the caracteristic frequencies of the

correlation function.
B graphl CI=1=]
12 J 3

XorY
S 5 2 °
o N £ (=] o Ll

-200 -100 0 100 200

T T T T T T T T T T T T T T T T T T T T 7
-0.1 -0.05 o] 0.05 0.1

frequency (Hz)

Figure 6.2: An example of a correlation between two sinus functions.

The correlation of a signal with itself can also be used in spectral analysis (it is then
called autocorrelation or autocovariance function).

6.3 Convolution

6.4 Deconvolution

6.5 Non Linear Curve Fit

This function can be accessed by the command Non Linear Curve Fit.... It can be found
in the Analysis Menu when a table is selected.
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The results are shown in the log window, the curve is plotted in the active window,
and a table is created to store the fit.

& Exponential decay fit of tabled_2, using function: y=Aexp(-x/t)+y0
Scaled Levenberg-Marguardt algorithrm with tolerance = 0.0001
From x=0 to x=20

A=0.42497 +/- 112141

| t=4.89755 +/- 1.55796

y0=0.56022 +/- L.O09B0D

= | terations = 6
Status = success

ES gr 0 |-} =1x]

i 4 Datapoints

¥ Values

T
0 5 10 15 20
X values

Figure 6.3: The results of the Non Linear Curve Fit....

6.6 Fitting to specific curves

SciDAVis include quick access to the most usefull functions for fitting.

6.6.1 Fitting to a line

This command is used to fit a curve which has a linear shape.
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EZ graph2 _h=0x] |

(&3]

3.5 -
L] 12 3 ] ©  tablez 2
2| 3 25 B = LinearFits_2 |
EN a 2.4 3]
4 | 5 21 ]
5 | 6 1.73 1
6 | 7 1.35 25
7 8 1.24 ] o
(8 | 8.7 1.07 >4
o | 2
(10 | ]
12| ]
perer 15
= ] o]
12 @ ]
e lY———7 7T T T T 1

2 3 Fl 5 7 8 9
X

Figure 6.4: The results of a Fit Linear.

The results will be given in the Log panel:

% Ao
11.05.2006 22:29:50 LinearFit3:
Linear regresion of table2_2: y=Ax+B
From x=1.2to x=8.7

;‘ A= -0.266281 +/- 0.0126381

B |B = 3.35168 +/- 0.0742493

@

£ | sumsq = 0,0441584
Rsquare = 0,986665

6.6.2 Fitting to a polynome

This command is used to fit a curve which has a linear shape. The results will be given
in the Log panel

Polynomial Fit Options o'x

Eit
Polynomial Fit of Tahlel_z = —
Close
Fit curve # pts 100 E

Fit curve Xmin
Fit curve Kmax

Calor e red

- [ =
L1

Show Formula on Graph?
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|_A2Ax} [& graph2 =l 2] %]
10x] 2[Y] L)
2.01 I 3 Py

.10, 07 ot! ra
[29.10.2006 00:07:50 Plot: "graph2"] E

Polynemial fit of dataset: table2_2, using function: a0 + al*x + a2x"2
Weighting Method: Mo weightin

Fror?'\x:gl.ztcx= 10.01g ? " 8 10
al = 3.47399146217575 +/- 0.0905606989647793

al -0.47967965687217 +/- 0.0351197055047098
a2 0.0308610113448932 +/- 0.00302648396530548

Chi~2/doF = 0.00412591
R™~2 = 0.984248

«w| ]

Figure 6.5: The results of a Fit Polynomial..., showing the initial data, the curve added
to the plot, and the results in the log panel.

6.6.3 Fitting to a Bolzmann function

This command is used to fit a curve which has a sigmoidal shape. The function used

is:

—x
X JOH
de ||

[ [
y= .4:—.4,||l+exp| T
| |

EQUATION 6.6.1: Bolzmann equation

in which A; is the high Y limit, A; is the low Y limit, xg is the inflexion point and
dx is the width.
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Figure 6.6: The results of a Fit Bolzmann (sigmoidal).

6.6.4 Fitting to a Gauss function
This command is used to fit a curve which has a bell shape. The function used is:
y=y,tAexp |: %:|

EQUATION 6.6.2: Gauss equation

in which A is the height, w is the width, x. is the center and yy is the Y-values
offset.

B8 graph2 CI=1=]
(&3]
2.2
L] 1 11 © tamez_zl o
Ex 2 1| = ritiz
3] 3 2
la | 4 i
s | 5 154
6 | 6 1
17 | 7 1.35 1
s | 8 1.24 > 16
EXl 9 1.07 ]
| 10] 10 1.0 L4+
11] i
[12] 121
13 ]
1 @ ]
Sl T 7 T T 1
0 2 a 6 8 10
x

Figure 6.7: The results of a Fit Gaussian.
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6.6.5 Fitting to a Lorentz function

This command is used to fit a curve which has a bell shape. The function used is:

A w
V=Yt 2= ———————
T4 x—x, [ +w

EQUATION 6.6.3: Lorentz equation
in which A is the area, w is the width, x. is the center and yy is the Y-values offset.
i table2 BE graph2 k=]

© table2 2 I

— Fit0_2

1.35 1
1.24 B
1.07 ]
1.05 1.4

=R A R A A T AN

-

[elelslzlsle[= [ [= [~ ]7]

Figure 6.8: The results of a Fit Lorentzian.

6.7 Multi-Peaks fitting

This kind of fitting allows to fit your data points to a sum of N gaussian or lorentzian

functions.

The first step is to specify the number of peaks. Then you must define the position
of each peak on the curve. This is done by clicking on the plot, then validate your
choice for each peak with the ENTER key.
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B graph2 Cl=I=]
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9 1.7
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11 1.2
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Figure 6.9: The results of a Fit Multi-peak ->Gaussian....

6.8 Filtering of data curves
In this section, it will be assumed that you have the following data curve:

1%

L
b

[ graphl
&
8 -

20 40 60 80 100

This signal has a power spectrum with high and low frequencies. We can analyze
this by doing a FFT on the data curve, this leads to the following figure:
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The newt sections will show the influence of the different filters on this data curve.

6.8.1 FFT low pass filter

This filter allows to cut the high frequencies of a signal. You just have to select the cut-
off frequency of the filter. Let us assume that we want to keep the frequencies below 1
Hz, we will obtain:

[ Graphl

5 —

0
»
[x

MW s
|
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8
&
8
8
é

Figure 6.10: Signal after a FFT low pass filter

The power spectrum of this new signal shows that the frequencies below 1 Hz have
been kept.
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6.8.2 FFT high pass filter

This filter allows to cut the low frequencies of a signal. You just have to select the cut-
off frequency of the filter. Let us assume that we want to keep the frequencies above 1
Hz, we will obtain:

[ highpass = [ (2]
L]

g -

.

=

5

4]

3

2

1

0

-1

-2 i

34

4

5

6

74

8 T T T T 1

(4] 20 40 60 80 100

Figure 6.11: Signal after a FFT high pass filter

The power spectrum of this new signal shows that the frequencies above 1 Hz have
been kept.
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6.8.3 FFT band pass filter

This filter allows to cut the low and high frequencies of a signal. You just have to select
the high and low cut-off frequencies of the filter. Let us assume that we want to keep
the frequencies between 1.5 and 3.5 Hz, we will obtain:

E8 bandpass

0 20 40 60 80 100

Figure 6.12: Signal after a FFT band pass filter

The power spectrum of this new signal shows that only the frequencies at 2 and 3
Hz have been kept.
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6.8.4 FFT block band filter

This filter allows to keep the low and high frequencies of a signal. You just have to
select the high and low cut-off frequencies of the filter. Let us assume that we want to
remove the frequencies between 1.5 and 3.5 Hz, we will obtain:

E2 block |_J =] I

L
6 —

Figure 6.13: Signal after a FFT block band filter

The power spectrum of this new signal shows that only the frequencies below 1.5
Hz and above 3.5 Hz have been kept.

111



[ fftblock = 2] (2]
(&3]
14
0.8
5 0.6~
ES J
=2
I
< 0.4 -
0.2
o1 L Il
Tt 1 T T T T 1
] -4 2 0 2 4 6
Frequency (Hz)

6.9 Interpolation

The interpolation command will create a new data curve with a high number of points
by interpolation of your data. The dialog box allows to define this number of points
(default value = 1000). Then the method used for interpolation, the interval of X-values
and the color of the interpolated curve can be chosen. In addition to the new curve in
the active plot, a new table will be created.

Interpolation Options olx
Make curve from | Table1_2 =
.
[=]
Points 1000 =
Calor o red S

The simplest interpolation method is the linear method. In this case, a linear varia-
tion is used to compute the data points between two values. The cubic method will use
the Cubic Splines method (in this case at least 4 points are needed). The last method
Akima is a polynomial interpolation. You can refer to the corresponding section of the
GNU Scientific Library for more details.
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Figure 6.14: Comparison of the three methods of interpolation
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Chapter 7

Mathematical Expressions and
Scripting

SciDAVis supports different interpreters for evaluating mathematical expressions and
for executing scripts.

7.1 muParser

The constants _e=e=E and _pi=pi=PI=Pi are defined, as well as the following operators
and functions. muParser is purely a parser for mathematical expressions and as such
does not support executing scripts.

Name | Description

+ Addition

- Substraction

* Multiplication

/ Division

- Exponentiation (raise a to the power of b)

and logical and (returns O or 1)

or logical or (returns O or 1)

Xor logical exclusive or (returns O or 1)

< less then (returns O or 1)

<= less then or equal (returns O or 1)

== equal (returns O or 1)

>= greater then or equal (returns O or 1)
greater then (returns O or 1)

1= not equal (returns O or 1)

Table 7.1: Supported Mathematical Operators
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Name | Description

abs(x) | absolute value of x

acos(x) | inverse cosinus

acosh(x) inverse hyperbolic cosinus

asin(x) | inverse sinus

asinh(x)| inverse hyperbolic sinus

atan(x) | inverse tangent

atanh(x)| inverse hyperbolic tangent

ave(x] A Zegyfra e value, this command accept a list of arguments separated by
torias

bessel_jO(Regular cylindrical Bessel function of zeroth order, Jo(x).

bessel_jl(Regular cylindrical Bessel function of first order, J;(x).

bessel_jh(Regular cylindrical Bessel function of n™ order, J,(x).

bessel_yO@xpegular cylindrical Bessel function of zeroth order, Y (x) for x>0.
bessel_y/1Txdegular cylindrical Bessel function of first order, Y;(x) for x>0.
bessel_yn({xragular cylindrical Bessel function of n™ order, Y,,(x) for x>0.
beta Computes the Beta Function, B(a,b) =
(a,b) Gamma(a)*Gamma(b)/Gamma(a+b) fora> 0 and b > 0.
cos(x) | cosinus of x
cosh(x) | hyperbolic cosinus of x
erf(x) error function of x
erfc(x) | Complementary error function erfc(x) = 1 - erf(x).
erfz(x) | The Gaussian probability density function Z(x).
erfq(x) | The upper tail of the Gaussian probability function Q(x).
exp(x) | Exponential function: e raised to the power of x.
Computes the Gamma function, subject to x not being a negative inte-
gamma( K)ger
1 C)omputes the logarithm of the Gamma function, subject to X not a
gamma n(ﬁeing negative integer. For x<0, log(IGamma(x)l) is returned.
Computes the hazard function for the normal distribution h(x) =
hazard(x)
erfz(x)/erfq(x).
In(x) natural logarythm of x
log(x) | decimal logarythm of x
log2(x) | base 2 logarythm of x
min(x1,x2Mimum of the list of arguments
max(x1,xvk8ximum of the list of arguments
rint(x) | Round to nearest integer.
sign(x) | Sign function: -1 if x<0; 1 if x>0.
sin(x) sinus of x
sinh(x) | hyperblic sinus of x
sqrt(x) | square root of x
tan(x) | tangent of x
tanh(x) | hyperbolic tangent of x

Table 7.2: Mathematical Functions
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Name | Description

In the contex of a matrix, returns the value at row a and column b. In
the context of a table, returns the value at column a and row b (remem-
ber that tables use column logic). Everywhere else, this function is
undefined.

Only works in the context of a table. Returns the value at column ¢
col(c) and row i (the current row) in the context table. ¢ can either be the
column’s number, or its name in doublequotes.

if(el,e2,e3f el is true, e2 is executed else e3 is executed.

Only works in the context of a table. Returns the value at column ¢ and
tablecol(t,c0w i (the current row) in the table t. t is the table’s name in double-
quotes, c is either the column’s number or its name in doublequotes.

cell(a,b)

Table 7.3: Non-Mathematical Functions

7.2 Python

This module provides bindings to the Python programming language. Basic usage in
the context of SciDAVis will be discussed below, but for more in-depth information on
the language itself, please refer to its excellent documentation.

7.2.1 Getting Started

Make sure your current project uses Python as its interpreter by selecting the menu
point Scripting->Scripting Language and double-clicking on "Python" in the resulting
dialog (if the dialog appears, but does not contain the "Python" item, your installation
of SciDAVis has been compiled without Python support). Next, open a Notes window
and enter print "Hello World!". Position the cursor anywhere on this line and
press Ctrl+], or select "Execute” from the context menu. The string "Hello World!"
should appear below the line you entered. Congratulations, you’ve made contact with
Python! You can also enter more complex code fragments, such as function or class
definitions, in which case you have to select the whole code block before executing it.

You can also use Notes windows as a handy calculator. Enter a mathematical ex-
pression on a line of its own - say, 5xsin (pi/2). Press Ctr+Enter, or select "Eval-
uate" from the context menu. You are rewarded by a new line, stating (to general
astonishment), that the result of evaluating your expression is #> 5. If you have SciPy
and/or PyGSL installed, you will have immediate access to a huge number of interest-
ing functions, browsable via the submenu "Functions" of the context menu. Pressing
Shift+F1 while in this menu will give you a short description of the current function.
The advantage of only executing/evaluating single lines or selections on request is that
you can freely mix text and calculations within a Notes window.

Another particularly handy place for using Python code are column formulas. These
work just like evaluating expressions in Note windows, with the additional advantage
of some pre-defined variables: i (the row currently being computed), j (the column
number), sr (start row), er (end row) and self (the table to which the column being

116


http://www.python.org
http://www.python.org/doc
http://www.scipy.org
http://pygsl.sf.net

computed belongs; see below for what you can do with it).

If you are already familiar with Python, you might ask yourself at this point if you
can use more complicated column formulas than just single expressions (for instance,
if:/else: decisions based on the current row number). The answer is: yes, you can. For
the benefit of those not familiar with Python, we will give a short introduction to the
language before discussing how to do this.

7.2.2 Python Basics
7.2.2.1 Expressions

Mathematical expressions work largely as expected. However, there’s one caveat, es-
pecially when switching from muParser: a“b does not mean "raise a to the power of
b" but rather "bitwise exclusive or of a and b"; Python’s power operator is **. Thus:

273 # read: 10 xor 11 = 01
#> 1
2x%3
#> 8

7.2.2.2 Statements

One thing you have to know when working with Python is that indentation is very
important. It is used for grouping (most other languages use either braces or keywords

like do. . . end for this). For example, executing the following:
x=23
for i in (1,4,5):

xX=1x*2

print (x)

will do what you would expect: it prints out the numbers 1, 16 and 25; each on a line
of its own. Deleting just a bit of space will change the functionality of your program:

x=23
for i in (1,4,5):
X=1%%2

print (x)

will print out only one number - no, not 23, but rather 25. This example was designed
to also teach you something about variable scoping: There are no block-local variables
in Python.

There are two different variable scopes to be aware of: local and global variables.
Unless specified otherwise, variables are local to the context in which they were de-
fined. Thus, the variable x can have three different values in, say, two different Note
windows and a column formula. Global variables on the other hand can be accessed
from everywhere within your project. A variable x is declared global by executing the
statement global x. You have to do this before assigning a value to x, but you have
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to do it only once within the project (no need to "import" the variable before using it).
Note that there is a slight twist to these rules when you define your own functions.

The basic syntax for defining a function (for use within one particular note, for
example) is

def answer () :
return 42

If you want your function to be accessible from the rest of your project, you have to
declare it global before the definition:

global answer
def answer () :
return 42

You can add your own function to SciDAVis’s function list. We’ll also provide a docu-
mentation string that will show up, for example, in the "set column values" dialog:

global answer
def answer () :
"Return the answer to the ultimate <«
question about life, the
universe and everything."
return 42
sci.mathFunctions["answer"] = answer

If you want to remove a function from the list, execute

del sci.mathFunctions["answer"]

Note that functions have their own local scope. That means that if you enter a
function definition in a Notes window, you will not be able to access (neither reading
nor writing) Notes-local variables from within the function. However, you can access
global variables as usual.

If-then-else decisions are entered as follows:

if x>23:
print (x)
else:
print ("The value is too small.")

You can do loops, too:

for i in range(l, 11):
print (i)

This will print out the numbers between 1 and 10 inclusively (the upper limit does not
belong to the range, while the lower limit does).
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7.2.3 Evaluation Reloaded

As we’ve already mentioned above, there’s a bit more to evaluation than just expres-
sions. Note that Python itself can indeed only evaluate expressions; the following
describes a feature of SciDAVis added on top of Python in order to support more inter-
esting column formulas.

If you use statements (e.g. variable assignments or control structures) in a formula,
SciDAVis will assume it to be the body of a function. That is, the following code will
not work:

a=1
ata

The statement in the first line means that the formula cannot be evaluated as a single
expression. Instead, the above code assigns every row in the column the return value
of the following function:

def f£():
a=1
ata

However, since Python does not implicitly interpret expressions as something to return,
this evaluates to nothing. The correct way to enter formulas with statements in them is
to explicitly return something:

a=1
return ata

There is a slight catch associated with this strategy. In a Notes window, SciDAVis
will allow you to evaluate variable assignments like ee=1.6021773e-19 without
complaining - but this will not lead to the result presumably intended, i.e. introducing
a shortcut for the elementary charge to be used within the notes window. What actually
happens is this: SciDAVis evaluates the function

def f£():
ee=1.6021773e-19

As mentioned in the Python introduction above, the function f has its own variable
scope and (unless it happens to be declared global) the variable ee will only be visible
within this scope (instead of the Notes window’s scope). The solution is simple: always
execute things like assignments and function definitions, never evaluate them.

7.2.4 Mathematical Functions

Python comes with some basic mathematical functions that are automatically imported
(if you use the initialization file shipped with SciDAVis). Along with them, the con-
stants e (Euler’s number) and pi (the one and only) are defined. Many, many more
functions can be obtained by installing SciPy and/or PyGSL.
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Name | Description
acos(X) | inverse cosinus
asin(x) | inverse sinus
atan(x) | inverse tangent

atan2(y,x)equivalent to atan(y/x), but more efficient

ceil(x) | ceiling; smallest integer greater or equal to x
cos(x) | cosinus of x
cosh(x) | hyperbolic cosinus of x

degrees(x)convert angle from radians to degrees

exp(x) | Exponential function: e raised to the power of x.

fabs(x) | absolute value of x

floor(x) | largest integer smaller or equal to x

fmod(x,y)remainder of integer division x/y
Returns the tuple (mantissa,exponent) such that

frexp(x)| x=mantissa*(2**exponent) where exponent is an integer and 0.5
<=abs(m)<1.0

hypot(x,lyequivalent to sqrt(x*x+y*y)

ldexp(x,y)equivalent to x*(2**y)

log(x) | natural (base e) logarythm of x

logl0(x) decimal (base 10) logarythm of x

modf(x)| return fractional and integer part of x as a tuple

pow(X,y) x to the power of y; equivalent to x**y

radians(x)convert angle from degrees to radians

sin(x) sinus of x

sinh(x) | hyperblic sinus of x

sqrt(x) | square root of x

tan(x) | tangent of x

tanh(x) | hyperbolic tangent of x

Table 7.4: Supported Mathematical Functions
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7.2.5 Accessing SciDAVis’s functions from Python

We will assume that you are using the initialization file shipped with SciDAVis.

7.2.5.1 Establishing contact
Accessing the objects in your project is straight-forward,

= table ("Tablel")

= matrix ("Matrixl")
= graph ("Graphl")

= note ("Notesl")

5 Q B
|

as is creating new objects:

4=

create an empty table named "tony" <«
with 5 rows and 2 columns:

= newTable ("tony", 5, 2)

use defaults

= newTable ()

create an empty matrix named "gina <«
" with 42 rows and 23 columns:

= newMatrix ("gina", 42, 23)

use defaults

= newMatrix ()

HH= t H=

create an empty graph window

= newGraph ()

create an empty note named "momo"
= note ("momo")

use defaults

= note ()

S 5 #=Q w3 w3

New objects will always be added to the active folder. The functions table, matrix,
graph and note will start searching in the active folder and, failing this, continue with a
depth-first recursive search of the project’s root folder. In order to access other folders,
there are the functions

f = activeFolder ()
# and
f = rootFolder ()

which can be used to access subfolders and windows:

f2 = f.folders () [number]

f2 = f.folder (name, caseSensitive= <
True, partialMatch=False)

t = f.table (name, recursive=False)

m f.matrix (name, recursive=False)

g = f.graph(name, recursive=False)

n f.note (name, recursive=False)
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If you supply True for the recursive argument, a depth-first recursive search of all
subfolders will be performed and the first match returned.

Also, every piece of code is executed in the context of an object which you can ac-
cess via the self variable. For example, entering self.cell ("t", 1) asacolumn
formula is equivalent to the convenience function col ("t").

7.2.5.2 Working with Tables

We’ll assume that you have assigned some table to the variable t. You can access its
numeric cell values with

t.cell (col, row)
# and
t.setCell (col, row, value)

Whenever you have to specify a column, you can use either the column name (as a
string) or the consecutive column number (starting with 1). Row numbers also start
with 1, just as they are displayed. If you want to work with arbitrary texts or the textual
representations of numeric values, you can use

t.text (col, row)
# and
t.setText (col, row, string)

The number of columns and rows is accessed via

.numRows ()
.numCols ()
.setNumRows (number)
.setNumCols (number)

ot o

Column names can be read and written with

t.colName (number)
t.setColName (col, newName)

Normalize a single or all columns:

t.normalize (col)
t.normalize ()

Import values from £ile, using sep as separator char and ignoring ignore lines at
the head of the file. The flags should be self-explanatory.

t.importASCII(file, sep="\t", ignore «
=0, renameCols=False, —
stripSpaces=True, simplifySpace= <
False, newTable=False)

After having changed some table values from a script, you will likely want to update
dependent Graphs:
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t.notifyChanges ()

As a simple example, let’s set some column values without using the dialog.

t = table("tablel")

for i in range(l, t.numRows()+1):
t.setCell(1l, i, 1*x2)

t.notifyChanges ()

7.2.5.3 Working with Matrices

We’ll assume that you have assigned some matrix to the variable m. Accessing cell val-
ues is very similar to Table, but since Matrix doesn’t use column logic, row arguments
are specified before columns and obviously you can’t use column name.

.cell (row, col)

.setCell (row, col, wvalue)
.text (row, col)

.setText (row, col, string)

58 58 B

Also like with tables, there’s

m.numRows ()
# and
m.numCols ()

7.2.5.4 Plotting and Working with Graphs

If you want to create a new Graph window for some data in table tablel, you can use
the plot command:

g = plot (table, column, type)
type is a number between 0 and 10 and specifies the desired plot type:
0. Line

1. Symbols

Line and Symbols

Columns

Area

Pie

Vertical drop lines

NS,k ow N

Splines and Symbols
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8. Vertical steps
9. Histogram
10. Rows

You can plot more than one column at once by giving a Python tuple (see the Python
Tutorial) as an argument:

g = plot (table("tablel"), (2,4,7), <«
2)

If you want to add a curve to an existing Graph window, you have to choose the
destination layer. Usually,

1 = g.activelayer ()

will do the trick, but you can also select a layer by its number:

1 = g.layer (num)

You can then add or remove curves to or from this layer:

l.insertCurve (table, column, type=1l)

1l.insertCurve (table, Xcolumn, <«
Ycolumn, type=1l)

1.removeCurve (curveName)

1l.removeCurve (curveNumber)

l.deleteFitCurves ()

In case you need the number of curves on a layer, you can get it with

1.numCurves ()

Layers and whole Graphs can be printed and exported from within Python. Before
you do this, you would probably want to change layer and axis titles as well as legend
texts:

.setTitle(title)
.setXTitle (Xtitle)
.setYTitle(Ytitle)
.setLegend (text)

o e

You can also customize the scales of the different axes using:

l.setScale (int axis, double start, <«
double end, double step=0.0, int <>
majorTicks=5, int minorTicks=5, <
int type=0, bool inverted=False <
)i

where axis is a number between 0 and 3 with the following signification:

0. Left axis
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1. Right axis

2. Bottom axis

3. Top axis

type specifies the desired scale type:
0. Linear

1. Logl0

and step defines the size of the interval between the major scale ticks. If not specified
(default value is 0.0), the step size is calculated automatically. The other flags should
be self-explanatory. Now, here is how you can export a layer

.print ()

.exportToSVG (filename)

.exportToEPS (filename)

.exportImage (filename, filetype=" <
PNG", quality=100, transparent= <>
False)

o e

and a graph
g.print ()

g.exportToSVG (filename)
g.exportToEPS (filename)

7.2.5.5 Fitting

Assuming you have a Graph named "graphl" with a curve entitled "tablel_2" (on its
active layer), a minimal Fit example would be:

f = GaussFit (graph ("graphl"). <
activelLayer (), "tablel_ 2")

f.guessInitialValues ()

f.fit ()

This creates a new GaussFit object on the curve, lets it guess the start parameters and
does the fit. The following fit types are supported:

* LinearFit(layer, curve)

* PolynomialFit(layer, curve, degree=2, legend=False)
» ExponentialFit(layer, curve, growth=False)

* TwoExpFit(layer, curve)

» ThreeExpFit(layer, curve)

* GaussFit(layer, curve)
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* GaussAmpFit(layer, curve)
 LorentzFit(layer,curve)

» SigmoidalFit(layer, curve)
* NonLinearFit(layer, curve)

f = NonLinearFit (layer, curve)
f.setParameters (namel, ...)
f.setFormula (formula_string)

* PluginFit(layer, curve)

f = PluginFit (layer, curve)
f.load(pluginName)

For each of these, you can optionally restrict the X range that will be used for the fit,
like in

f = LinearFit (graph("graphl"). <
activelayer (), "tablel_2", 2, 7)
f.fit ()

After creating the Fit object and before calling its fit() method, you can set a number
of parameters that influence the fit:

f.setDataFromCurve (curve) change data source

f.setDataFromCurve (curve, graph) change data source
f.setDataFromCurve (curve, from, to) change data source
f.setDataFromCurve (curve, from, to, graph) change data source
f.setInterval (from, to) change data range

f.setInitialValue (number, value)

f.setInitialValues (valuel, ...)

f.guessInitialValues ()

f.setAlgorithm(algo) # algo = Fit.ScaledLevenbergMarquardt, Fit.

UnscaledLevenbergMarquardt, Fit.NelderMeadSimplex

.setWeightingData (method, colname) # method = Fit.NoWeighting, Fit. <
Instrumental, Fit.Statistical, Fit.Dataset

.setTolerance (tolerance)

.setOutputPrecision (precision)

.setMaximumIterations (number)

.scaleErrors (yes = True)

.setColor (gt.QColor ("green")) change the color of the result fit
curve to green (default color is red)

h

FhoFh oHh Fh b

After you’'ve called fit(), you have a number of possibilities for extracting the re-
sults:

f.results ()
f.errors ()
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.chiSquare ()

.rSquare ()

.dataSize ()
.numParameters ()
.parametersTable ("params")
.covarianceMatrix ("cov")

FhoFhoFh R R

7.2.6 The Initialization File

This file allows you to customize the Python environment, import modules and define
functions and classes that will be available in all of your projects. The default initial-
ization file shipped with SciDAVis imports Python’s standard math functions as well
as special functions from SciPy and PyGSL(if available). Also, it creates some handy
shortcuts, like table ("tablel") for sci.app.table ("tablel").

When activating Python support, SciDAVis searches the following places, execut-
ing the first file it can find:

1. ~/.scidavisrc.py[c]
2. /etc/scidavisre.py|c]
3. ./scidavisrc.py|[c]

Files ending in .pyc are compiled versions of the .py source files and therefore load
a bit faster. The compiled version will be used if the source file is older or nonexistent.
Otherwise, SciDAVis will try to compile the source file (if you’ve got write permissions
for the output file).
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Appendix A

Appendix

A.1 Credits and License

SciDAVis

Program copyright:

2004-2007 Ion Vasilief ion_vasilief@yahoo.fr

2006-2007 Tilman Hoener zu Siederdissen thzs @ gmx.net

2006-2007 Knut Franke Knut.Franke @gmx.de

Documentation copyright:

2004-2007 Ion Vasilief ion_vasilief @yahoo.fr

2006-2007 Roger Gadiou Roger.Gadiou@uha.fr

2006-2007 Knut Franke Knut.Franke @ gmx.de

Permission is granted to copy, distribute and/or modify this document under the
terms of the GNU Free Documentation License, Version 1.1 or any later version pub-
lished by the Free Software Foundation; with no Invariant Sections, with no Front-
Cover Texts, and with no Back-Cover Texts.

A.1.1 GNU Free Documentation License

Version 1.1, March 2000

Copyright (C) 2000 Free Software Foundation, Inc. 51 Franklin Street, Fifth Floor,
Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license docu-
ment, but changing it is not allowed.

A.1.1.1 Preamble

The purpose of this License is to make a manual, textbook, or other written document
"free" in the sense of freedom: to assure everyone the effective freedom to copy and
redistribute it, with or without modifying it, either commercially or noncommercially.
Secondarily, this License preserves for the author and publisher a way to get credit for
their work, while not being considered responsible for modifications made by others.
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This License is a kind of "copyleft", which means that derivative works of the
document must themselves be free in the same sense. It complements the GNU General
Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software,
because free software needs free documentation: a free program should come with
manuals providing the same freedoms that the software does. But this License is not
limited to software manuals; it can be used for any textual work, regardless of sub-
ject matter or whether it is published as a printed book. We recommend this License
principally for works whose purpose is instruction or reference.

A.1.1.2 Applicability And Definitions

This License applies to any manual or other work that contains a notice placed by
the copyright holder saying it can be distributed under the terms of this License. The
"Document", below, refers to any such manual or work. Any member of the public is a
licensee, and is addressed as "you".

A "Modified Version" of the Document means any work containing the Document
or a portion of it, either copied verbatim, or with modifications and/or translated into
another language.

A "Secondary Section" is a named appendix or a front-matter section of the Doc-
ument that deals exclusively with the relationship of the publishers or authors of the
Document to the Document’s overall subject (or to related matters) and contains noth-
ing that could fall directly within that overall subject. (For example, if the Document
is in part a textbook of mathematics, a Secondary Section may not explain any mathe-
matics.) The relationship could be a matter of historical connection with the subject or
with related matters, or of legal, commercial, philosophical, ethical or political position
regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are desig-
nated, as being those of Invariant Sections, in the notice that says that the Document is
released under this License.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover
Texts or Back-Cover Texts, in the notice that says that the Document is released under
this License. A "Transparent" copy of the Document means a machine-readable copy,
represented in a format whose specification is available to the general public, whose
contents can be viewed and edited directly and straightforwardly with generic text edi-
tors or (for images composed of pixels) generic paint programs or (for drawings) some
widely available drawing editor, and that is suitable for input to text formatters or for
automatic translation to a variety of formats suitable for input to text formatters. A
copy made in an otherwise Transparent file format whose markup has been designed
to thwart or discourage subsequent modification by readers is not Transparent. A copy
that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without
markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly
available DTD, and standard-conforming simple HTML designed for human modifi-
cation. Opaque formats include PostScript, PDF, proprietary formats that can be read
and edited only by proprietary word processors, SGML or XML for which the DTD
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and/or processing tools are not generally available, and the machine-generated HTML
produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following
pages as are needed to hold, legibly, the material this License requires to appear in the
title page. For works in formats which do not have any title page as such, "Title Page"
means the text near the most prominent appearance of the work’s title, preceding the
beginning of the body of the text.

A.1.1.3 Verbatim Copying

You may copy and distribute the Document in any medium, either commercially or
noncommercially, provided that this License, the copyright notices, and the license
notice saying this License applies to the Document are reproduced in all copies, and
that you add no other conditions whatsoever to those of this License. You may not
use technical measures to obstruct or control the reading or further copying of the
copies you make or distribute. However, you may accept compensation in exchange
for copies. If you distribute a large enough number of copies you must also follow the
conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may
publicly display copies.

A.1.1.4 Copying In Quantity

If you publish printed copies of the Document numbering more than 100, and the Doc-
ument’s license notice requires Cover Texts, you must enclose the copies in covers that
carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover,
and Back-Cover Texts on the back cover. Both covers must also clearly and legibly
identify you as the publisher of these copies. The front cover must present the full title
with all words of the title equally prominent and visible. You may add other mate-
rial on the covers in addition. Copying with changes limited to the covers, as long as
they preserve the title of the Document and satisfy these conditions, can be treated as
verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should
put the first ones listed (as many as fit reasonably) on the actual cover, and continue the
rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than
100, you must either include a machine-readable Transparent copy along with each
Opaque copy, or state in or with each Opaque copy a publicly-accessible computer-
network location containing a complete Transparent copy of the Document, free of
added material, which the general network-using public has access to download anony-
mously at no charge using public-standard network protocols. If you use the latter op-
tion, you must take reasonably prudent steps, when you begin distribution of Opaque
copies in quantity, to ensure that this Transparent copy will remain thus accessible at
the stated location until at least one year after the last time you distribute an Opaque
copy (directly or through your agents or retailers) of that edition to the public.
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It is requested, but not required, that you contact the authors of the Document well
before redistributing any large number of copies, to give them a chance to provide you
with an updated version of the Document.

A.1.1.5 Modifications

You may copy and distribute a Modified Version of the Document under the conditions
of sections 2 and 3 above, provided that you release the Modified Version under pre-
cisely this License, with the Modified Version filling the role of the Document, thus
licensing distribution and modification of the Modified Version to whoever possesses a
copy of it. In addition, you must do these things in the Modified Version:

Use in the Title Page (and on the covers, if any) a title distinct from that of the
Document, and from those of previous versions (which should, if there were any, be
listed in the History section of the Document). You may use the same title as a previous
version if the original publisher of that version gives permission.

List on the Title Page, as authors, one or more persons or entities responsible for
authorship of the modifications in the Modified Version, together with at least five of
the principal authors of the Document (all of its principal authors, if it has less than
five). State on the Title page the name of the publisher of the Modified Version, as the
publisher. Preserve all the copyright notices of the Document.

Add an appropriate copyright notice for your modifications adjacent to the other
copyright notices.

Include, immediately after the copyright notices, a license notice giving the public
permission to use the Modified Version under the terms of this License, in the form
shown in the Addendum below.

Preserve in that license notice the full lists of Invariant Sections and required Cover
Texts given in the Document’s license notice.

Include an unaltered copy of this License.

Preserve the section entitled "History", and its title, and add to it an item stating at
least the title, year, new authors, and publisher of the Modified Version as given on the
Title Page. If there is no section entitled "History" in the Document, create one stating
the title, year, authors, and publisher of the Document as given on its Title Page, then
add an item describing the Modified Version as stated in the previous sentence.

Preserve the network location, if any, given in the Document for public access to
a Transparent copy of the Document, and likewise the network locations given in the
Document for previous versions it was based on. These may be placed in the "History"
section. You may omit a network location for a work that was published at least four
years before the Document itself, or if the original publisher of the version it refers to
gives permission.

In any section entitled "Acknowledgements" or "Dedications”, preserve the sec-
tion’s title, and preserve in the section all the substance and tone of each of the contrib-
utor acknowledgements and/or dedications given therein.

Preserve all the Invariant Sections of the Document, unaltered in their text and in
their titles. Section numbers or the equivalent are not considered part of the section
titles. Delete any section entitled "Endorsements". Such a section may not be included
in the Modified Version.
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Do not retitle any existing section as "Endorsements" or to conflict in title with any
Invariant Section.

If the Modified Version includes new front-matter sections or appendices that qual-
ify as Secondary Sections and contain no material copied from the Document, you may
at your option designate some or all of these sections as invariant. To do this, add their
titles to the list of Invariant Sections in the Modified Version’s license notice. These
titles must be distinct from any other section titles.

You may add a section entitled "Endorsements", provided it contains nothing but
endorsements of your Modified Version by various parties--for example, statements of
peer review or that the text has been approved by an organization as the authoritative
definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage
of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the
Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text
may be added by (or through arrangements made by) any one entity. If the Document
already includes a cover text for the same cover, previously added by you or by arrange-
ment made by the same entity you are acting on behalf of, you may not add another;
but you may replace the old one, on explicit permission from the previous publisher
that added the old one.

The author(s) and publisher(s) of the Document do not by this License give per-
mission to use their names for publicity for or to assert or imply endorsement of any
Modified Version.

A.1.1.6 Combining Documents

You may combine the Document with other documents released under this License,
under the terms defined in section 4 above for modified versions, provided that you
include in the combination all of the Invariant Sections of all of the original documents,
unmodified, and list them all as Invariant Sections of your combined work in its license
notice.

The combined work need only contain one copy of this License, and multiple iden-
tical Invariant Sections may be replaced with a single copy. If there are multiple In-
variant Sections with the same name but different contents, make the title of each such
section unique by adding at the end of it, in parentheses, the name of the original au-
thor or publisher of that section if known, or else a unique number. Make the same
adjustment to the section titles in the list of Invariant Sections in the license notice of
the combined work.

In the combination, you must combine any sections entitled "History" in the vari-
ous original documents, forming one section entitled "History"; likewise combine any
sections entitled "Acknowledgements", and any sections entitled "Dedications". You
must delete all sections entitled "Endorsements."

A.1.1.7 Collections Of Documents

You may make a collection consisting of the Document and other documents released
under this License, and replace the individual copies of this License in the various
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documents with a single copy that is included in the collection, provided that you follow
the rules of this License for verbatim copying of each of the documents in all other
respects.

You may extract a single document from such a collection, and distribute it individ-
ually under this License, provided you insert a copy of this License into the extracted
document, and follow this License in all other respects regarding verbatim copying of
that document.

A.1.1.8 Aggregation With Independent Works

A compilation of the Document or its derivatives with other separate and independent
documents or works, in or on a volume of a storage or distribution medium, does not
as a whole count as a Modified Version of the Document, provided no compilation
copyright is claimed for the compilation. Such a compilation is called an "aggregate",
and this License does not apply to the other self-contained works thus compiled with
the Document, on account of their being thus compiled, if they are not themselves
derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Doc-
ument, then if the Document is less than one quarter of the entire aggregate, the Docu-
ment’s Cover Texts may be placed on covers that surround only the Document within
the aggregate. Otherwise they must appear on covers around the whole aggregate.

A.1.1.9 Translation

Translation is considered a kind of modification, so you may distribute translations of
the Document under the terms of section 4. Replacing Invariant Sections with trans-
lations requires special permission from their copyright holders, but you may include
translations of some or all Invariant Sections in addition to the original versions of
these Invariant Sections. You may include a translation of this License provided that
you also include the original English version of this License. In case of a disagreement
between the translation and the original English version of this License, the original
English version will prevail.

A.1.1.10 Termination

You may not copy, modify, sublicense, or distribute the Document except as expressly
provided for under this License. Any other attempt to copy, modify, sublicense or
distribute the Document is void, and will automatically terminate your rights under
this License. However, parties who have received copies, or rights, from you under this
License will not have their licenses terminated so long as such parties remain in full
compliance.

A.1.1.11 Future Revisions Of This License

The Free Software Foundation may publish new, revised versions of the GNU Free
Documentation License from time to time. Such new versions will be similar in spirit to
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the present version, but may differ in detail to address new problems or concerns. See
http:///www.gnu.org/copyleft/. Each version of the License is given a distinguishing
version number. If the Document specifies that a particular numbered version of this
License "or any later version" applies to it, you have the option of following the terms
and conditions either of that specified version or of any later version that has been
published (not as a draft) by the Free Software Foundation. If the Document does not
specify a version number of this License, you may choose any version ever published
(not as a draft) by

A.2 How to obtain SciDAVis

The SciDAVis home page can be found at http://sourceforge.net/project/scidavis. Up-
dates and news can be found there.

SciDAVis is distributed as a package with sources which have to be compiled. Com-
piled packages suitable for most Linux distributions and Windows can also be obtained.
If you want to build SciDAVis from sources, don’t forget first to download and install
the Qt, QwtPlot3D, Qwt, liborigin, zlib, muParser, and GSL libraries.

A.3 Requirements

In order to successfully use SciDAVis, you need the following libraries:

Qt >=4.2 SciDAVis uses the Qt toolkit. Version 4.2 or above is needed. It provides
the necessary dynamic libraries to run the SciDAVis binaries and important tools
to compile it.

Qwt You need to install the Qwt library version 5.0.0 or above. It is recommended to
use the latest release. Qwt must be compiled with Qt 4.x.

muParser You also need the muParser library 1.28 or later.

liborigin The latest version of the liborigin is required for the import of Origin OPJ
project files.

Qwtplot3d The 3D plots in SciDAVis make use of qwtplot3d. The library and must
be available in version 0.2.6 or higher.

GSL Furthermore, the GNU Scientific Library (GSL) (1.8 or later) must be installed
on your system.

Zlib Additionally, zIlib >=1.2.3 is required. Since this is also a requirement of Qt,
installing Qt should fullfill this requirement on most systems.

Python scripting If you want to use Python expressions and scripts, make sure you
have the following additional dependencies installed: Python 2.5, SIP 4.5.2 or
4.6, PyQt 4.2. Other versions as those indicated above may or may not work.
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A.4 Installation from binary packages

SciDAVis distributes binaries which can be downloaded from the SciDAVis page on
Sourceforge. Refer to the installation instructions and requirements there. Typically,
you need at least Qt and Python installed on your system.

A.5 Compilation and Installation from sources

To compile SciDAVis from sources, download the latest source distribution from the
SciDAVis page on Sourceforge. It comes as a zip or tar.gz achive containing detailed
building instructions. If you are insterested in the current development, you can also
obtain a snapshot from the SciDAVis SVN repository.
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Appendix B

Frequently asked questions

Q: How can I visualise data from a text file?
A: Go to the File menu and select the Import ASCII -> Single File... command com-
mand.If the file is not imported correctly, change the columns separator using the
Set Import Options... command options command from the File menu .The default
columns separator is the TAB.

Q: How can I plot data from a table (worksheet)?
A: Click on the table header to choose the columns to plot and then right click. Chose
the "Plot’ option from the pop-up menu and then the type of plot you want. You can also
use the plot assistant: press ’CTRL+ALT+W’ keys to show it, or go to *View’ menu ->
"Plot wizard’.

Q: How can I export a plot to an image format?
A: Right click in the plot window and chose the Export’ option.

Q: Can I export transparent images?
A: Yes, ".png" images have transparent background. See the Export Graph -> Current
command command.

Q: How can I export a text file?
A: Go to the File menu and select the Export ASCII command command.

Q: How can I choose a window using the project explorer?
A: Double click on the window name will show the window maximized, even if it was
hidden before.

Q: How can I choose the data range from a plot curve, when doing a curve fit?
A: Go to the Data menu and use the Select Data Range command command. Click
in the plot window and use the *Up’ and 'Down’ arrows keys to select the curve to
analyse. Keeping *CTRL’ button and ’Left’ or 'Right’ arrow keys simultaneousely
pressed permit to move the selected cursor and consequently to modify the data range.

Q: Can I fit a plot curve using my own function?
A: Go to the Analysis menu and select the Non Linear Curve Fit... command command.
Define the function (myFunction=...), enter the initial guesses for the parameters, sep-
arated by comas, choose the fitting range and the number of iterations and click ’OK’

Q: How can I visualize a pixel line profile from an image?
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A: Right click on the image you want to analyse and select the option ’View pixel
line profile’ from the popup menu. A dialog window opens and allows you to select
the number of pixels used for the analysis. Choose a value and click "OK". Then
click on the image to select the start point and move your mouse to select an end point
while keeping the left button pressed. When you release the left button a plot window
appears, representing the pixel intensity versus pixel index.
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Index

A Options, 86
Arrows and Lines
Add an arrow/line, 68 P
Plot, 5, 11
C Add a curve, 65
Curve analysis Change default options, 87
Curve filtering, 107 Create a new plot, 24
Band pass FFT, 110 Create from data, 11
Block pass FFT, 111 Create from function, 14
High pass FFT, 109 Create with the assistant, 84
Low pass FFT, 108 Curves options, 72
Curve fitting Error bars, 62
Bolzmann function, 104 Plot a function, 63
Gaussian function, 105 Properties, 81
line, 102 Remove a curve, 65
Lorentz function, 106 Printing, 91
Multi peak, 106 Project explorer, 85
Non linear function, 79, 101
Polynom, 103 S
FFT, 78, 99 Scripting, 114
Integration, 79 MuParser, 114
interpolation, 112 Python, 116
Mathematical functions, 119
F Surface plot, 16
Filtering, see Curve analysis Change default options, 87
Coutour curves options, 70
M . Create a new surface plot, 24
Matrix, 5,7 . Create from data, 19
CFeate anew mafrix, 24 Create from function, 17, 77
D.1mer.1$1ons, 92. Options, 97
Fill with a function, 94 Properties, 95
Import from file, 93
Properties, 94 T
Multilayers plot, 20 Table, 4, 6
Add a new layer, 65 Columns
Organize the layers, 67 Fill with values, 92
o Properties, 69
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Create a new table, 24
Export to file, 77
Import from file, 93
Table analysis
Convolution, 101
Correlation function, 100
Deconvolution, 101
Text label
Add a text label, 66
Properties, 97
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